XAMPP 1.7.3 phpmyadmin does not recognize new MySQL password

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

XAMPP 1.7.3 phpmyadmin does not recognize new MySQL password

Postby kkathman » 14. July 2011 01:25

I installed XAMPP per directions, everything works including phpMyAdmin, except that the root for mysql has no password, which I don't like!

Went to mysql and changed assigned a root password per normal:

sudo /Applications/XAMPP/xamppfiles/bin/mysqladmin -u root password mypassword

I verified this worked by starting the MySQL Workbench. All the databases and tables come up fine.

I then went to /Applications/XAMPP/xamppfiles/phpmyadmin and opened the config.inc.php file, and modified line 34 to put my password between the quotes for the server as I set above:

$cfg['Servers'][$i]['password'] = 'mypassword';

I saved the file. Stopped MySQL and Apache, restarted.

PhpMyAdmin reports access denied for root @ localhost (using password: YES)

What the heck? This has worked just fine before!

Mac OS X Snow Leopard 10.6.8

Is there another step I'm missing?
Posts: 7
Joined: 27. June 2007 05:49

Re: XAMPP 1.7.3 phpmyadmin does not recognize new MySQL pass

Postby JonB » 15. July 2011 02:26

what is your 'auth_type'?

the other penetrating question for me is "why are you 'quoting' Line 34, (which seems to be the pma control user's password), while giving the correct server syntax for the default user"??? I found that parameter is in line 21 - BUT you may have a differently conformed config.inc.php than I.


Anyway, good luck
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 7 guests