Apache2/MySQL configuration, "Invalid command 'DBDriver'"

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Apache2/MySQL configuration, "Invalid command 'DBDriver'"

Postby Nicsoft » 03. November 2010 18:56

Hello,

I am running into the wall over-and-over again trying to get Apache2 working with MySQL. What I want to do is to use mod_dbd when authenticating users that should have access to certain web-pages on Apache.

I've done a lot of things, the last thing I did was re-compiling Apache as this thread describes (I know it's for Ubuntu, but I guess it works about the same for OsX): http://ubuntuforums.org/showthread.php?t=757353

Code: Select all
./configure --prefix=/usr/local/apache2 --with-apr=/usr/local/apache2 --with-apr-util=/usr/local/apache2 --enable-mods-shared=all
make
sudo make install


Now, I'm not sure if it worked since I got this error, both when making and installing it (first time I am trying to compile and install):

Code: Select all
/usr/local/apache2/build-1/libtool --silent --mode=link gcc -g -O2        -o httpd  modules.lo buildmark.o -export-dynamic server/libmain.la modules/http/libmod_http.la modules/mappers/libmod_so.la server/mpm/prefork/libprefork.la os/unix/libos.la  /Users/Niklas/Development/apache/httpd-2.2.17/srclib/pcre/libpcre.la /usr/local/apache2/lib/libaprutil-1.la -lexpat -liconv /usr/local/apache2/lib/libapr-1.la -lpthread
Undefined symbols:
  "_apr_dir_read$INODE64", referenced from:
      _process_resource_config_nofnmatch in libmain.a(config.o)
      _ap_process_resource_config in libmain.a(config.o)
  "_apr_file_info_get$INODE64", referenced from:
      _ap_pcfg_openfile in libmain.a(util.o)
  "_apr_dir_open$INODE64", referenced from:
      _process_resource_config_nofnmatch in libmain.a(config.o)
      _ap_process_resource_config in libmain.a(config.o)
  "_apr_stat$INODE64", referenced from:
      _ap_process_resource_config in libmain.a(config.o)
      _ap_mpm_set_coredumpdir in libmain.a(mpm_common.o)
      _ap_is_directory in libmain.a(util.o)
      _ap_is_rdirectory in libmain.a(util.o)
      _ap_log_pid in libmain.a(log.o)
      _unixd_pre_config in libos.a(unixd.o)
      _resolve_symlink in libmain.a(request.o)
      _resolve_symlink in libmain.a(request.o)
      _resolve_symlink in libmain.a(request.o)
      _ap_directory_walk in libmain.a(request.o)
      _ap_directory_walk in libmain.a(request.o)
      _ap_directory_walk in libmain.a(request.o)
      _ap_sub_req_lookup_dirent in libmain.a(request.o)
      _ap_sub_req_lookup_dirent in libmain.a(request.o)
      _ap_sub_req_lookup_file in libmain.a(request.o)
      _ap_sub_req_lookup_file in libmain.a(request.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[1]: *** [httpd] Error 1
make: *** [install-recursive] Error 1


Why am I getting those errors?

Before I compiled Apache I did install the latest MySQL-drive using their .dmg download (32-bit).

Before I did the make/make install above, I followed instructions here trying to get it to work, I don't think I got the same error as above: http://snippets.dzone.com/posts/show/6301

I didn't remove the old installation, just compiled it according to the new instructions and installed it again.

I was also trying to figure out how to get the "apr_dbd_mysql.so" in place, but according to the link above this shouldn't be possible.

It feels like I am getting close, I really need help getting the last pieces together...

These is the significant part of my httpd.conf file

Code: Select all
# mod_dbd configuration
DBDriver mysql
DBDParams "dbname=ia_timereporting user=root@localhost pass="

DBDMin  4
DBDKeep 8
DBDMax  20
DBDExptime 300

<Directory /usr/local/apache2/htdocs/area1>
   AuthType Basic
   AuthName "Area1"
   # (Following line optional)
   AuthBasicProvider dbd
   Require valid-user
   AuthDBDUserPWQuery \
    "SELECT password FROM users WHERE user = %s"

</Directory>

<Directory /usr/local/apache2/htdocs/area2>
   AuthType Basic
   AuthName "Area2"
   # (Following line optional)
   AuthBasicProvider dbd
   Require valid-user
   AuthDBDUserPWQuery \
    "SELECT password FROM users WHERE user = %s"
</Directory>


I'm not really getting anywhere with google anymore...

Thank you in advance!
Getting Apache2 and MySQL working together, getting "Invalid command 'DBDriver'"
Regards,
Niklas
Nicsoft
 
Posts: 1
Joined: 03. November 2010 18:52

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests