error 404

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

error 404

Postby sugarplum_19 » 02. October 2010 15:02

I have just download xampp on to my mac, however when I want to preview my php page it says
Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404

localhost
Sat Oct 2 14:43:06 2010
Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1

i have saved my file in http://localhost/Applications/XAMPP/xam ... /hello.php
sugarplum_19
 
Posts: 1
Joined: 02. October 2010 14:42

Re: error 404

Postby MegaChriz » 02. October 2010 15:58

By default, XAMPP's localhost starts with 'htdocs' (localhost is pointing to /Applications/XAMPP/xamppfiles/htdocs/ by default).
If you go to http://localhost/hello.php you should see your php page.
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
Operating System: Mac OS X

Re: error 404

Postby hsands » 04. October 2010 10:44

MegaChriz wrote:By default, XAMPP's localhost starts with 'htdocs' (localhost is pointing to /Applications/XAMPP/xamppfiles/htdocs/ by default).
If you go to http://localhost/hello.php you should see your php page.


I've been using XAMPP for years in Windows. Some months ago I installed 1.7.3 version in my iMac 20" (OS X 10.5.8) and it's running like a charm. Now I installed the same version in a Mac Pro (OS X 10.6.2) and have the same problem, any URL produces a 404 error:
http://localhost/
http://localhost/index.php
http://localhost/myfolder/
http://localhost/myfolder/index.php

However, pointing to native OS X standard Sites folder shows the default page OS X page:
http://localhost/~user/

Web Sharing is disabled in System Preferences > Sharing and Apache and MySQL started through XAMPP Control Panel

Thanks in advance

hsands
hsands
 
Posts: 5
Joined: 04. October 2010 10:18

Re: error 404

Postby MegaChriz » 04. October 2010 11:20

Look if there any hints in the log files.

What does the file error_log contain?
You can find this file at:
/Applications/XAMPP/xamppfiles/logs/error_log
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
Operating System: Mac OS X

Re: error 404

Postby hsands » 04. October 2010 11:31

I won't be able to check it until Thursday when I visit again the place where that computer is installed. I'll let you know the results

Thanks for your time

hsands

Edit: I just asked a friend with a Mac Pro and OS X 10.6 to install XAMP 1.7.3 and in 5 minutes he had it working as usual !!!???
hsands
 
Posts: 5
Joined: 04. October 2010 10:18

Re: error 404

Postby hsands » 11. October 2010 21:06

This the content of error_log:

[Fri Oct 01 16:24:35 2010] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri Oct 01 16:24:36 2010] [notice] Digest: generating secret for digest authentication ...
[Fri Oct 01 16:24:36 2010] [notice] Digest: done
[Fri Oct 01 16:24:36 2010] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri Oct 01 16:25:15 2010] [error] [client ::1] File does not exist: /Applications/XAMPP/xamppfiles/htdocs/xampp
[Fri Oct 01 16:25:26 2010] [error] [client ::1] File does not exist: /Applications/XAMPP/xamppfiles/htdocs/xampp
[Fri Oct 01 16:25:33 2010] [error] [client ::1] File does not exist: /Applications/XAMPP/xamppfiles/htdocs/xampp, referer: http://localhost/xampp/
[Fri Oct 01 16:25:45 2010] [error] [client ::1] File does not exist: /Applications/XAMPP/xamppfiles/htdocs/xampp
[Fri Oct 01 16:25:54 2010] [error] [client ::1] File does not exist: /Applications/XAMPP/xamppfiles/htdocs/xampp
[Fri Oct 01 16:26:50 2010] [error] [client ::1] File does not exist: /Applications/XAMPP/xamppfiles/htdocs/xampp
[Fri Oct 01 16:30:21 2010] [error] [client ::1] File does not exist: /Applications/XAMPP/xamppfiles/htdocs/xampp
[Fri Oct 01 16:34:58 2010] [error] [client ::1] File does not exist: /Applications/XAMPP/xamppfiles/htdocs/xampp
[Fri Oct 01 16:44:39 2010] [notice] caught SIGTERM, shutting down
...

The first time I downloaded XAMPP in another Mac and copy it in a pen drive as there wasn't internet connection at that time. Having now internet access, I decided to download XAMPP again, moved to the Trash the old one and in 5 minutes it was running ok !?
hsands
 
Posts: 5
Joined: 04. October 2010 10:18

Re: error 404 help

Postby Matt G » 06. November 2010 00:48

hey everyone, I just purchased my macbook 2 days ago and I have downloaded the most recent version of the xampp bundle and the most recent "all in one" eclipse for PHP developers (eclipse-php-helios-SR1-macosx-cocoa-x86_64.tar.gz )..after loading them both "correctly" and setting the eclipse workspace to (/Applications/XAMPP/xamppfiles/htdocs/xampp), i created a PHP project and file.. I performed a basic test script "hello world" but when I checked the output on the browser http://localhost/simple_blog/test.php ...i receive this error

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404

localhost
Fri Nov 5 16:43:51 2010
Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1



my xampp status indicates that everything is properly activated and working..
what am i doing wrong please help!
Matt G
 
Posts: 5
Joined: 06. November 2010 00:11

Re: error 404

Postby hsands » 06. November 2010 02:11

I'd check the log file as MegaChriz adviced to me: /Applications/XAMPP/xamppfiles/logs/error_log
hsands
 
Posts: 5
Joined: 04. October 2010 10:18

Re: error 404

Postby Matt G » 06. November 2010 20:00

Thanks, here is the error report although must say im not sure what it all means:

[Tue Nov 02 22:21:25 2010] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Tue Nov 02 22:21:27 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Nov 02 22:21:27 2010] [notice] Digest: done
[Tue Nov 02 22:21:28 2010] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Nov 02 22:44:07 2010] [error] [client ::1] File does not exist: /Applications/XAMPP/xamppfiles/htdocs/simple_blog
[Tue Nov 02 22:46:26 2010] [error] [client ::1] File does not exist: /Applications/XAMPP/xamppfiles/htdocs/Applications, referer: viewtopic.php?f=29&t=42120
[Tue Nov 02 22:46:35 2010] [error] [client ::1] script '/Applications/XAMPP/xamppfiles/htdocs/hello.php' not found or unable to stat, referer: viewtopic.php?f=29&t=42120
[Tue Nov 02 22:47:24 2010] [error] [client ::1] script '/Applications/XAMPP/xamppfiles/htdocs/hello.php' not found or unable to stat
[Tue Nov 02 22:47:50 2010] [error] [client ::1] script '/Applications/XAMPP/xamppfiles/htdocs/hello.php' not found or unable to stat, referer: viewtopic.php?f=29&t=42120
[Tue Nov 02 23:23:25 2010] [notice] caught SIGTERM, shutting down
[Fri Nov 05 16:40:41 2010] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri Nov 05 16:40:43 2010] [notice] Digest: generating secret for digest authentication ...
[Fri Nov 05 16:40:43 2010] [notice] Digest: done
[Fri Nov 05 16:40:44 2010] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri Nov 05 16:43:51 2010] [error] [client ::1] File does not exist: /Applications/XAMPP/xamppfiles/htdocs/simple_blog
[Fri Nov 05 16:53:24 2010] [notice] caught SIGTERM, shutting down

The November 5th logs are the errors i have received with my current xampp bundle and eclipse bundle..
Matt G
 
Posts: 5
Joined: 06. November 2010 00:11


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests