Pecl packages don't work on XAMPP MAC.

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Pecl packages don't work on XAMPP MAC.

Postby CODEVOMIT » 11. July 2010 10:14

Hi all,

I have tried installing the pecl_http on the mac version of XAMPP using the pecl install command, it downloaded and built the nessasary files and placed an entry into php.ini. I discovered that pelc in XAMPP on Mac builds for the wrong cpu architecture, so I followed this tutorial http://blog.m-schmidt.eu/2010/03/30/dev ... -mac-os-x/ but replaced
Code: Select all
pecl download memcache
with
Code: Select all
pecl download pecl_http
. Built the file in the correct architecture and manually placed an entry into php.ini. but I still get a fatal missing class 'HttpRequest' error when I try to use it. I tryed using the pear version but I get a message saying HTTP_Request has already been installed, I don't know how to remove anything that's been installed using 'make install'.

Anybody been successful?

Thanks in advance.
CODEVOMIT
 
Posts: 2
Joined: 11. July 2010 10:05

Re: Pecl packages don't work on XAMPP MAC.

Postby CODEVOMIT » 11. July 2010 10:16

I've checked my error log:-

Code: Select all
PHP Warning:  PHP Startup: Unable to load dynamic library '/Applications/XAMPP/xamppfiles/lib/php/php-5.3.1/extensions/no-debug-non-zts-20090626/html.so' - dlopen(/Applications/XAMPP/xamppfiles/lib/php/php-5.3.1/extensions/no-debug-non-zts-20090626/html.so, 9): image not found in Unknown on line 0


Not sure what image not found means in this case.
CODEVOMIT
 
Posts: 2
Joined: 11. July 2010 10:05


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 7 guests