PHP wont parse

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

PHP wont parse

Postby antenando » 20. April 2010 23:12

Greetings, gentlemen. I'm awfully sorry I can't speak German but please, bear with me on this one.

My problem persists in all of the many attempts of clean-installation of XAMPP 1.7.3 and 1.7.2 on my Mac OS Snow Leopard. Doing exactly what I'm supposed to do, copying the XAMPP folder from the .DMG file into the /Applications folder, php is not being executed neither http://localhost nor http://127.0.0.1

I open the Control Panel, start both Apache and MySQL servers and then, whatever the browser is, http://localhost or http://127.0.0.1 just points me to actually *download* the php file.

THe php5_module is loading fine and AddType application/x-httpd-php .php .php3 .php4 is correctly inserted from the included file (Include etc/extra/httpd-xampp.conf) at the bottom line of httpd.conf

Well, it seems to me there's definitely something preventing php files to be parsed. They just don't run. HTML displays fine, though. Is it anything regarding permissions?

Anyway, if I open the php file download by the browser, which was supposed to be displayed instead, I can read this:

<?php
if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
$uri = 'https://';
} else {
$uri = 'http://';
}
$uri .= $_SERVER['HTTP_HOST'];
header('Location: '.$uri.'/xampp/');
exit;
?>
Something is wrong with your XAMPP installation :-(


And my /etc/hosts is:

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost
127.0.0.1 localhost


THanks very much indeed in advance.

Fernando Bueno
antenando
 
Posts: 1
Joined: 20. April 2010 22:29

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests