MySQL failing to start due to wrong symlink

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

MySQL failing to start due to wrong symlink

Postby nferro » 25. December 2009 18:18

Hello,

I just installed XAMPP on Snow Leopard, my disk is formatted in case sensitive so I was having trouble starting MySQL, after a bit of debugging I found that the symbolic link was being wrongly created:
Code: Select all
xamppfiles ferro$ sudo ./xampp startmysql
Password:
XAMPP: Starting MySQL...ok.
xamppfiles ferro$ ./xampp: line 150: /Applications/XAMPP/xamppfiles//bin/mysql.server: No such file or directory
Nuno-Ferros-Mac-Pro:xamppfiles ferro$ ls -l /Applications/XAMPP/xamppfiles//bin/mysql.server
lrwxr-xr-x  1 ferro  admin  55 Aug 16 13:35 /Applications/XAMPP/xamppfiles//bin/mysql.server -> /Applications/xampp/xamppfiles/share/mysql/mysql.server
xamppfiles ferro$ sudo /Applications/xampp/xamppfiles/share/mysql/mysql.server
sudo: /Applications/xampp/xamppfiles/share/mysql/mysql.server: command not found
xamppfiles ferro$ sudo /Applications/XAMPP/xamppfiles/share/mysql/mysql.server
Usage: /Applications/XAMPP/xamppfiles/share/mysql/mysql.server  {start|stop|restart|reload|force-reload|status}  [ MySQL server options ]

So I fixed the symbolic link:
Code: Select all
xamppfiles ferro$ sudo rm /Applications/XAMPP/xamppfiles/bin/mysql.server
xamppfiles ferro$ sudo ln -s /Applications/XAMPP/xamppfiles/share/mysql/mysql.server /Applications/XAMPP/xamppfiles/bin/mysql.server
xamppfiles ferro$ sudo /Applications/XAMPP/xamppfiles/bin/mysql.server
Usage: /Applications/XAMPP/xamppfiles/bin/mysql.server  {start|stop|restart|reload|force-reload|status}  [ MySQL server options ]
nferro
 
Posts: 1
Joined: 25. December 2009 18:10

Re: MySQL failing to start due to wrong symlink

Postby TShirt » 10. January 2010 20:30

Same error!
Same fix!

Thanks!!!


Bye...
TShirt
 
Posts: 9
Joined: 07. June 2008 11:26

Re: MySQL failing to start due to wrong symlink

Postby bismarck_vp » 19. April 2011 06:44

Gracias, funciona... :D

Thanks, it works ... :D
bismarck_vp
 
Posts: 2
Joined: 18. April 2011 14:50


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 5 guests