Cannot Locate Perl Modules

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Cannot Locate Perl Modules

Postby hzrdc2 » 13. November 2009 18:07

I have XAMPP running on OS X 10.5.8... in my web root I have a cgi that calls some perl modules

When I execute the page, I get:

Can't locate Text/Template.pm in @INC (@INC contains: /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/darwin-2level /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0 /Applications/XAMPP/xamppfiles/lib/perl5/site_perl/5.10.0/darwin-2level /Applications/XAMPP/xamppfiles/lib/perl5/site_perl/5.10.0 .) at /Applications/XAMPP/xamppfiles/htdocs/calendar/index.cgi line 12.
BEGIN failed--compilation aborted at /Applications/XAMPP/xamppfiles/htdocs/calendar/index.cgi line 12.


the header of my cgi is #!/Applications/xampp/xamppfiles/bin/perl

when I go to /Applications/xampp/xamppfiles/bin
and do a sudo cpan then install Text::Template I get:

cpan> install Text::Template
Text::Template is up to date.


If I comment out Text::Template, it then fails on send mail... and so on.

What am I doing wrong?

BTW... my path is as follows export PATH=/opt/local/bin:/opt/local/sbin:/Applications/XAMPP/xamppfiles/bin:$PATH
hzrdc2
 
Posts: 3
Joined: 13. November 2009 17:59

Re: Cannot Locate Perl Modules

Postby Wiedmann » 13. November 2009 18:16

and do a sudo cpan then install Text::Template I get:

I guess it should be:
Code: Select all
sudo ./cpan
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Cannot Locate Perl Modules

Postby hzrdc2 » 13. November 2009 18:29

AH.... yes, that worked... the only module install that is failing now is Image::Magick


Code: Select all
cpan[1]> install Image::Magick
CPAN: Storable loaded ok (v2.20)
Going to read '/Users/Scott/.cpan/Metadata'
  Database was generated on Thu, 12 Nov 2009 07:27:01 GMT
Running install for module 'Image::Magick'
Running make for J/JC/JCRISTY/PerlMagick-6.57.tar.gz
CPAN: LWP::UserAgent loaded ok (v5.829)
CPAN: Time::HiRes loaded ok (v1.9719)
Warning: no success downloading '/Users/Scott/.cpan/sources/authors/id/J/JC/JCRISTY/PerlMagick-6.57.tar.gz.tmp1508'. Giving up on it. at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/FTP.pm line 837
   CPAN::FTP::hostdlhard('CPAN::FTP', 'ARRAY(0x8c5bf0)', 'authors/id/J/JC/JCRISTY/PerlMagick-6.57.tar.gz', '/Users/Scott/.cpan/sources/authors/id/J/JC/JCRISTY/PerlMagick...', 'HASH(0x4460ef0)') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/FTP.pm line 515
   CPAN::FTP::hostdlxxx('CPAN::FTP', 'dlhard', undef, 'ARRAY(0x8c5bf0)', 'authors/id/J/JC/JCRISTY/PerlMagick-6.57.tar.gz', '/Users/Scott/.cpan/sources/authors/id/J/JC/JCRISTY/PerlMagick...', 'HASH(0x4460ef0)') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/FTP.pm line 442
   CPAN::FTP::localize('CPAN::FTP', 'authors/id/J/JC/JCRISTY/PerlMagick-6.57.tar.gz', '/Users/Scott/.cpan/sources/authors/id/J/JC/JCRISTY/PerlMagick...') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/Distribution.pm line 379
   CPAN::Distribution::get_file_onto_local_disk('CPAN::Distribution=HASH(0x4244810)') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/Distribution.pm line 343
   CPAN::Distribution::get('CPAN::Distribution=HASH(0x4244810)') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/Distribution.pm line 1677
   CPAN::Distribution::make('CPAN::Distribution=HASH(0x4244810)') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/Distribution.pm line 2876
   CPAN::Distribution::test('CPAN::Distribution=HASH(0x4244810)') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/Distribution.pm line 3266
   CPAN::Distribution::install('CPAN::Distribution=HASH(0x4244810)') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/Module.pm line 474
   eval {...} called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/Module.pm line 473
   CPAN::Module::rematein('CPAN::Module=HASH(0x34c5870)', 'install') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/Module.pm line 576
   CPAN::Module::install('CPAN::Module=HASH(0x34c5870)') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/Shell.pm line 1755
   CPAN::Shell::rematein('CPAN::Shell', 'install', 'Image::Magick') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN/Shell.pm line 1935
   CPAN::Shell::__ANON__('CPAN::Shell', 'Image::Magick') called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN.pm line 375
   eval {...} called at /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/CPAN.pm line 372
   CPAN::shell() called at ./cpan line 198
Client not fully configured, please proceed with configuring.

You have not configured a urllist and do not allow connections to the
internet to get a list of mirrors.  If you wish to get a list of CPAN
mirrors to pick from, use this command

    o conf init connect_to_internet_ok urllist

If you do not wish to get a list of mirrors and would prefer to set
your urllist manually, use just this command instead

    o conf init urllist


cpan[2]>


This is my last hurdle, any help would be greatly appreciated... If I comment that out, all other modules are working.

I tried the suggested command: o conf init connect_to_internet_ok urllist to no avail.

Thanks in advance!
hzrdc2
 
Posts: 3
Joined: 13. November 2009 17:59

Re: Cannot Locate Perl Modules

Postby Wiedmann » 13. November 2009 19:29

I tried the suggested command: o conf init connect_to_internet_ok urllist to no avail.

What happens if you execute this command?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Cannot Locate Perl Modules

Postby hzrdc2 » 13. November 2009 19:52

I just ran it again... and this time it asked me to define a server list (north america, usa..) I saved it, ran install Image::Magick again... it seemed to download this time and start to install, but then it started spewing a lot of errors like this:

Code: Select all
Magick.xs:12951: error: ‘ExceptionInfo’ undeclared (first use in this function)
Magick.xs:12951: error: ‘exception’ undeclared (first use in this function)
Magick.xs:12951: error: invalid operands to binary *
Magick.xs:12954: error: ‘Image’ undeclared (first use in this function)
Magick.xs:12954: error: ‘image’ undeclared (first use in this function)
Magick.xs:12954: error: invalid operands to binary *
Magick.xs:13054: error: ‘OptionError’ undeclared (first use in this function)
Magick.xs:12957: error: ‘MagickBooleanType’ undeclared (first use in this function)
Magick.xs:12957: error: syntax error before ‘status’
Magick.xs:12971: error: ‘OptionError’ undeclared (first use in this function)
Magick.xs:13064: error: syntax error before ‘)’ token
Magick.xs:13064: error: called object ‘&<erroneous-expression>’ is not a function
Magick.xs:12978: error: syntax error before ‘)’ token
Magick.xs:12978: error: called object ‘&<erroneous-expression>’ is not a function
Magick.xs:12985: error: ‘status’ undeclared (first use in this function)
Magick.xs:12986: error: ‘MagickFalse’ undeclared (first use in this function)
Magick.xs:12988: error: ‘struct Methods’ has no member named ‘exception’
Magick.xs:12991: error: ‘MaxTextExtent’ undeclared (first use in this function)
Magick.xs:12991: error: ‘struct Methods’ has no member named ‘severity’
Magick.xs:12991: error: ‘UndefinedException’ undeclared (first use in this function)
Magick.xs:12991: error: ‘struct Methods’ has no member named ‘severity’
Magick.xs:12991: error: ‘struct Methods’ has no member named ‘reason’
Magick.xs:12991: error: ‘struct Methods’ has no member named ‘severity’
Magick.xs:12991: error: ‘struct Methods’ has no member named ‘reason’
Magick.xs:12991: warning: pointer/integer type mismatch in conditional expression
Magick.xs:12991: error: ‘struct Methods’ has no member named ‘description’
Magick.xs:12991: error: ‘struct Methods’ has no member named ‘description’
Magick.xs:12991: error: ‘struct Methods’ has no member named ‘severity’
Magick.xs:13104: error: ‘next’ undeclared (first use in this function)Magick.xs:12991: error: ‘struct Methods’ has no member named ‘description’


At the end it said:

Running make install
Make had returned bad status, install seems impossible


so... not sure what to make of all this??
hzrdc2
 
Posts: 3
Joined: 13. November 2009 17:59


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: Jwerton17 and 2 guests