port 80 taken, XAMPP's Apache

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

port 80 taken, XAMPP's Apache

Postby pawelpawel » 06. November 2009 15:06

Hi,

Sorry for posting a topic in English, my German is sehr slecht.

I'm trying to install XAMPP on mac OS x server and run it. Unfortunately apache tells me that the port 80 is taken. I tried editing the port in XAMPP's httpd.conf file but it doesn't seem to work.
I also tried switching off skype, what doesn't work as well.

Please take a look at the screenshot:
http://img692.imageshack.us/img692/1612 ... hot643.png

Any ideas on how to solve it?

Thanks for your help in advance,
Pawel
pawelpawel
 
Posts: 2
Joined: 06. November 2009 14:59

Re: port 80 taken, XAMPP's Apache

Postby jmdirc » 06. November 2009 15:49

Apache didn't really stop when you turned it off. I've run into this a couple of times. You can turn off apache by going into the terminal and turning it off XAMPP:

as root type in /Applications/XAMPP/xamppfiles/xampp stop

then you can turn it back on.
An artist/designer/ and now programer exploring the creative sides.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Re: port 80 taken, XAMPP's Apache

Postby pawelpawel » 06. November 2009 16:25

thanks for reply!

but the problem is that I can't start it (it says that something occupies the port 80, even though I've changed the port to 1234) so switching xampp off won't help.
pawelpawel
 
Posts: 2
Joined: 06. November 2009 14:59

Re: port 80 taken, XAMPP's Apache

Postby jmdirc » 06. November 2009 18:05

even though it says the port is blocked by something using it -- have you tried to turn XAMPP off and back on in the terminal - don't try to turn it on first
An artist/designer/ and now programer exploring the creative sides.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Re: port 80 taken, XAMPP's Apache

Postby zeebric » 10. November 2009 18:02

I know that with MAMP, to allow Apache to use 80 you have to make sure that Web Sharing is turned off in System Preferences > Sharing. I imagine it's the same for XAMPP.
zeebric
 
Posts: 1
Joined: 10. November 2009 17:44

Re: port 80 taken, XAMPP's Apache

Postby jmdirc » 12. November 2009 06:10

zeebric wrote:I know that with MAMP, to allow Apache to use 80 you have to make sure that Web Sharing is turned off in System Preferences > Sharing. I imagine it's the same for XAMPP.


You're quite right. If Web Sharing is turned on, Xampp will not start. Still, that error will usually specify 'Web Sharing' is turned on. Won't hurt to check though.
An artist/designer/ and now programer exploring the creative sides.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests