The configuration file now needs a secret passphrase (blowfi

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

The configuration file now needs a secret passphrase (blowfi

Postby Keith Romans » 03. November 2009 09:33

I have downloaded and installed XAMPP it seems to work But i Get. The additional features for working with linked tables have been deactivated. To find out why click here.
The configuration file now needs a secret passphrase (blowfish_secret). I don't know what to do to rectify the problem, your help would be appreciated.
Keith Romans
 
Posts: 21
Joined: 17. October 2009 06:25

Re: The configuration file now needs a secret passphrase (blowfi

Postby MegaChriz » 03. November 2009 11:31

This has something to do with the phpMyAdmin settings. For linking tables in the phpMyAdmin environment, you will need a database called 'phpmyadmin' and install the phpmyadmin tables. The tables will only be linked within phpMyAdmin. The link information will be stored in the phpmyadmin database.

1. In Finder, go to /Applications/XAMPP/xamppfiles/phpmyadmin/
2. Copy the file config.inc.php to your desktop.
3. Open the copied file in a text editor (Dreamweaver for example).
4. Look for the following phrase:
Code: Select all
$cfg['blowfish_secret'] = ''; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */
and fill in a couple of characters.

You will need a database called 'phpmyadmin' with the right tables.
5. In phpmyadmin, create a database called 'phpmyadmin'.
6. Click on the 'import'-tab.
7. Click on the 'browse'-button in order to select a file from the filesystem.
8. Look for create_tables.sql in /Applications/XAMPP/xamppfiles/phpmyadmin/scripts/ and select it.
9. Click on the start button. The needed tables will now be imported.

Now you need to activate the phpmyadmin settings in order to work with linking tables.
10. Go back to the config.inc.php-file on your desktop.
11. Uncomment the following lines (or add them if they don't exists in the file)
Code: Select all
/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';

12. Save the file.
13. Move the file on your desktop back to the folder /Applications/XAMPP/xamppfiles/phpmyadmin/. You will get a warning that the content of that folder can not be changed, but an administrator may. So click on the button 'identity control' (don't know what the button is exact called) and fill in the password of your Mac account. If that doesn't work, try to delete the old config.inc.php-file first.

Now you have the possibility to link tables in phpMyAdmin. When working with databases in phpmyadmin, you will now see a tab 'designer'. Please note that how the tables are linked is only visible in your phpmyadmin-installation. When you export the database and you import it into another webserver then the linking information will be gone (but you could export a part of the phpmyadmin database).

I know that there were other options for linking tables (within MySQL), but I didn't try that yet. It had something to with the InnoDB storage, I think.
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
Operating System: Mac OS X

Re: The configuration file now needs a secret passphrase (blowfi

Postby jmdirc » 03. November 2009 15:40

if you have set the security settings - go to:
/Applications/XAMPP/xamppfiles/phpmyadmin/

select the file: config.inc.php
ctrl click or right click and select Get Info:
change permissions from user nobody to you:
open the file:

Look for the following phrase:

$cfg['blowfish_secret'] = ' '; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */

replace with:

$cfg['blowfish_secret'] = ' put secret word here '; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */

save the document and close it. go back to permissions and reset to nobody


or--- if you have not set passwords yet, just go to the same file and add the blowfish secret
An artist/designer/ and now programer exploring the creative sides.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Re: The configuration file now needs a secret passphrase (blowfi

Postby Keith Romans » 05. November 2009 07:11

Here we go again Blowfish sorted now in myadmin I getThe additional features for working with linked tables have been deactivated. To find out why click here. When I click here I get pages of text and do not know what to do. Your help would be appreciated.
Also when I try to go to localhost it puts in /xampp and opens the orange page is this normal.
Keith Romans
 
Posts: 21
Joined: 17. October 2009 06:25

Re: The configuration file now needs a secret passphrase (blowfi

Postby jmdirc » 05. November 2009 08:18

In the htdocs folder there is a file called index.php. This is the folder and file that localhost is pointing to, when XAMPP is activated. Within that file there is a header sent which directs or 're-directs' to the xampp folder where it then grabs the index.php from that folder. From there, another header is sent, it is again redirected to the splash.php file for one condition and reads the file under another.

but, don't be alarmed, that is just making it sound complicated.

Using XAMPP for development, just add a folder in the htdocs folder with the name of your site and title the home page inside that folder 'index.php'. You will then be able to call it by going to localhost/folder_name/

or, if you want to work only on the htdocs directory, remove or replace that index.php with your own sites index.php / .html or what ever

as for the additional features - read through the documentation to see if any of those are things you need, if so, you will need to uncomment them in the config.inc.php in phpmyadmin - most likely not something you need to worry about
An artist/designer/ and now programer exploring the creative sides.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Re: The configuration file now needs a secret passphrase (blowfi

Postby Keith Romans » 05. November 2009 15:19

Thanks to you all xampp is now secure
I put joomla1.5 in anew folder in htdocs but can not access it on the server. Im entering htpp//localhost/Applications/XAMPP/htdocs/joomla1.5.
server or folder cant be found check spelling of url.
Canany body help please.
Keith Romans
 
Posts: 21
Joined: 17. October 2009 06:25

Re: The configuration file now needs a secret passphrase (blowfi

Postby jmdirc » 05. November 2009 17:55

After moving the joomla folder to the htdocs folder, First make sure you change the permissions on the joomla folder and its contents. I changed the name of the folder also, to just plain 'joomla'

then you will be able to access it by typing in http://localhost/joomla/
An artist/designer/ and now programer exploring the creative sides.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Re: The configuration file now needs a secret passphrase (blowfi

Postby Keith Romans » 06. November 2009 07:47

Thanks that work I am now into joomla installation Mysql set up page 4 what do I enter as database joomla dont work said create a data base but thats what this is all about I need to create a data base to make my web page. If i input localhost and enter /xampp appears on the command line and it asks for user name and password which opens the orange page fine but if I input localhost/Mysqlit says server cannot be found so it looks as though mysql is not set up properly, but i dont know.
Keith Romans
 
Posts: 21
Joined: 17. October 2009 06:25

Re: The configuration file now needs a secret passphrase (blowfi

Postby jmdirc » 06. November 2009 14:45

They probably mean to create a database. Don't look at mysql as a database - look at it as an engine that runs databases. Phpmyadmin is the tool where you create the database and tables for mysql, the engine. Open phpmyadmin and add one database. Joomla, during the installation process, will use that database to build the database tables it needs to operate.
An artist/designer/ and now programer exploring the creative sides.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Re: The configuration file now needs a secret passphrase (blowfi

Postby Keith Romans » 06. November 2009 21:09

Can't find server. In my phpadmin Iget a message saying things disabled cick here. andi get this Server: localhost
$cfg['Servers'][$i]['pmadb'] ... not OK [ Documentation ]
$cfg['Servers'][$i]['relation'] ... not OK [ Documentation ]
General relation features: Disabled

$cfg['Servers'][$i]['table_info'] ... not OK [ Documentation ]
Display Features: Disabled

$cfg['Servers'][$i]['table_coords'] ... not OK [ Documentation ]
$cfg['Servers'][$i]['pdf_pages'] ... not OK [ Documentation ]
Creation of PDFs: Disabled

$cfg['Servers'][$i]['column_info'] ... not OK [ Documentation ]
Displaying Column Comments: Disabled
Bookmarked SQL query: Disabled
Browser transformation: Disabled

$cfg['Servers'][$i]['history'] ... not OK [ Documentation ]
SQL history: Disabled

$cfg['Servers'][$i]['designer_coords'] ... not OK [ Documentation ]
Designer: Disabled
Keith Romans
 
Posts: 21
Joined: 17. October 2009 06:25

Re: The configuration file now needs a secret passphrase (blowfi

Postby jmdirc » 07. November 2009 06:44

All of those are advanced features you can uncomment in config.inc.php file. It is located in the phpmyadmin folder inside xamppfiles folder. If you have already set passwords you will need to change the permissions from nobody to you first - make the changes, then go back and reset the permissions to nobody. Until you change the permissions to you - the file, if you open it, will look blank.
An artist/designer/ and now programer exploring the creative sides.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Re: The configuration file now needs a secret passphrase (blowfi

Postby Keith Romans » 08. November 2009 14:25

There is not a nobody in config.inc.php how can i add a user named nobody.
Keith Romans
 
Posts: 21
Joined: 17. October 2009 06:25

Re: The configuration file now needs a secret passphrase (blowfi

Postby jmdirc » 08. November 2009 15:43

it isn't in the config file...

don't open the file
right click on its icon or control click on the config file
go down to 'get info'
scroll down to 'permissions'
click on 'details'
click on the little lock, it will ask for your password (your mac password)
change permission to you, then open the file and make the desired changes,
don't forget to reset the files original permisson when your done


Also, you may not know, you will need special tables in order to use the features you mentioned. note: If you're new to all this, you may just skip the new features all together for now. Otherwise, here is a little information about those features and how to get them going:

from the documentation Linked-tables infrastructure

For a whole set of new features (bookmarks, comments, SQL-history, PDF-generation, field contents transformation, etc.) you need to create a set of special tables. Those tables can be located in your own database, or in a central database for a multi-user installation (this database would then be accessed by the controluser, so no other user should have rights to it).

Please look at your ./scripts/ directory, where you should find a file called create_tables.sql.

If you already had this infrastructure and upgraded to MySQL 4.1.2 or newer, please use ./scripts/upgrade_tables_mysql_4_1_2+.sql.

You can use your phpMyAdmin to create the tables for you. Please be aware that you may need special (administrator) privileges to create the database and tables, and that the script may need some tuning, depending on the database name.

After having imported the ./scripts/create_tables.sql file, you should specify the table names in your ./config.inc.php file. The directives used for that can be found in the Configuration section. You will also need to have a controluser with the proper rights to those tables
An artist/designer/ and now programer exploring the creative sides.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Re: The configuration file now needs a secret passphrase (blowfi

Postby Keith Romans » 09. November 2009 13:29

Thats the end tried all i can for 5 week and after this mornings attempt i am further away than ever so thank you all very much for your help I'll try to buy a cheap package for mac and go another route. thanks again
Keith Romans
 
Posts: 21
Joined: 17. October 2009 06:25

Re: The configuration file now needs a secret passphrase (blowfi

Postby jmdirc » 09. November 2009 15:08

Go to lynda.com. Look up PHP on her list and take the video class. 25 bucks covers it if you complete in a month. Thats cheaper than any book on the subject. Kevin Skoglund does a good job teaching the class from installation of the tools to a finished CMS.
An artist/designer/ and now programer exploring the creative sides.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 10 guests