Control Panel Refuse

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Control Panel Refuse

Postby royster » 29. October 2009 10:29

yo mates. iv been trying to find the answer to this newbie question before i posted it , i recently installed xampp for mac (running leopard) and when im trying to "start" MySql - it says : "can not start while another mysql server is running. please turn it off and try again" .
well, apparently there is another thing running. but i have no idea what or what can cause this.

any simple solution ?
royster
 
Posts: 1
Joined: 29. October 2009 10:14

Re: Control Panel Refuse

Postby Nobbie » 29. October 2009 13:20

royster wrote:apparently there is another thing running. but i have no idea what or what can cause this.


Probably another MySQL Installation.
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: Control Panel Refuse

Postby MegaChriz » 30. October 2009 17:19

Mac OS X comes with a webserver already. Check if this turned on:
System Preferences -> Share -> Personal webserver
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
Operating System: Mac OS X

Another mysql server is already running!

Postby rossb » 09. November 2009 09:06

royster wrote:yo mates. iv been trying to find the answer to this newbie question before i posted it , i recently installed xampp for mac (running leopard) and when im trying to "start" MySql - it says : "can not start while another mysql server is running. please turn it off and try again" .
well, apparently there is another thing running. but i have no idea what or what can cause this.

any simple solution ?


I'm having the same problem - I DL'd the MySQL preferences pane, it tells me mySQL is not running...

I opened a terminal window and ran this then rebooted: sudo rm -rf /Library/StartupItems/MySQLCOM/

Still, no luck. I get this error every time I click on the MySQL start button: "Another mysql server is already running! XAMPP's MySQL can not start while another mysql server is running. Please turn it off and try again."

Any help would be appreciated...

Thanks!

R-
rossb
 
Posts: 1
Joined: 09. November 2009 08:57

Re: Control Panel Refuse

Postby jmdirc » 09. November 2009 15:48

Do you have a copy of mysql loaded on your computer that is not part of the XAMPP package?

If you do, go to preferences, to the round blue icon, and pull it up - check to see if 'Automatically start on startup' is checked - uncheck it and turn off MySql.

If not, turn off your webserver as MegaChriz suggested.

If that doesn't work, re-install XAMPP. Just throw out the entire folder from Application and then re-install. Maybe there was a glitch during the first install.
An artist/designer/ and now programer exploring the creative sides.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Re: Control Panel Refuse

Postby kleinweby » 09. November 2009 16:38

If nothing helps there is one last step to try: Turn of the check that the Control Panel performs.

Edit
Code: Select all
/Applications/XAMPP/XAMPP Control.app/Contents/PlugIns/MySQL.plugin/Contents/Info.plist

and Change RunStartTests from YES to NO.
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests