Drupal & XAMPP 1.7.2

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Drupal & XAMPP 1.7.2

Postby bravemenrun333 » 19. August 2009 13:23

Hello there

Thanks for all the effort youre putting in XAMPP.

The newest build 1.7.2 comes with PHP 5.3, which currently is not supported by Drupal 6.13 (newest release). So I wanted to install XAMPP 1.7.1 (I suppose this has PHP 5.2) - but I couldnt find 1.7.1 anywhere. On sourceforge theres only 1.7.2 which follows after 1.0.1. I installed 1.0.1 and drupal works, but Id like to have 1.7.1 certainly. Anyone knows where to get 1.7.1 and why isnt it on sourceforge?

Thanks & regards
bravemenrun333
 
Posts: 3
Joined: 19. August 2009 13:17

Re: Drupal & XAMPP 1.7.2

Postby Wiedmann » 19. August 2009 13:30

Anyone knows where to get 1.7.1 and why isnt it on sourceforge?

There is no XAMPP for Mac OS X version 1.7.1.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Drupal & XAMPP 1.7.2

Postby bravemenrun333 » 19. August 2009 13:47

so is it ok to use 1.0.1 on a production system until drupal handles 1.7.2? or should i use 1.7.2 and install php 5.2 manually?
bravemenrun333
 
Posts: 3
Joined: 19. August 2009 13:17

Re: Drupal & XAMPP 1.7.2

Postby Wiedmann » 19. August 2009 14:36

so is it ok to use 1.0.1 on a production system

No XAMPP is designed to use on a production system (only for development).

and install php 5.2 manually?

If you know how to to this... But I guess it's easier to use XAMPP 1.0.1.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Drupal & XAMPP 1.7.2

Postby Adrian B » 20. August 2009 11:52

The Drupal community is at least aware of the problem and are discussion a solution in this issue: PHP 5.3 Compatibility

Hopefully they will understand the need to support 5.3 in Drupal 6 and release an updated verison, but if they don't then at least there are patches available. The ereg warning is easy to deal with by suppressing the E_DEPRECATED warings. But there are other problems with 5.3 that needs to be patched.
Adrian B
 
Posts: 5
Joined: 20. August 2009 11:35

Re: Drupal & XAMPP 1.7.2

Postby paramajaya » 22. August 2009 04:30

Dear Bravemenrun333,

I am wondering if you have successfully installed XAMPP 1.7.2 with PHP 5.2 installed manually?
I have the same problem. I need Mercury to run as service in my windows 2003 server as well as tomcat. If I use XAMPP 171, mercury is not a service. If I use XAMPP 172, PHP 53 is a problem for Drupal 6.

Looking forward to hearing from you.
Please reply to my email: paramajaya at gmail.com
BTW, you can download all previous version of XAMPP at http://sourceforge.net/projects/xampp/files/
All the best and thanks
paramajaya
 
Posts: 2
Joined: 22. August 2009 04:18

Re: Drupal & XAMPP 1.7.2

Postby Adrian B » 16. September 2009 22:04

Drupal 6.14 (release today) supports PHP 5.3.
Adrian B
 
Posts: 5
Joined: 20. August 2009 11:35

Re: Drupal & XAMPP 1.7.2

Postby bravemenrun333 » 23. September 2009 16:27

Hello there, hello paramajaya
Sorry I didnt answer earlier.
I got D6.14 to work with XAMPP 1.72 by doing this:
http://drupal.org/node/583300
So D6.14 was not completely compatible with PHP5.3 for me...
Cheers
bravemenrun333
 
Posts: 3
Joined: 19. August 2009 13:17

Re: Drupal & XAMPP 1.7.2

Postby faddah » 08. October 2009 04:16

the fix at http://drupal.org/node/583300 also fixed this for me, tho' it is a php hack/workaround.

it's a drupal problem, using the "ereg" function in php in one of their install/set-up include files ("file.inc"), and that function is deprecated in php 5.3.0. the drupal gods need to update their code if they want to be truly php 5.3.0 compliant.
faddah
 
Posts: 1
Joined: 13. June 2009 06:12


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests