Disappearing PHP Help!

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Disappearing PHP Help!

Postby angstman » 18. August 2009 18:28

Hi - newbie here would really appreciate some help...

Mac Pro - OS 10.5.7.

Just paid $295.00 for "easy" e-commerce package - "Cartweaver 3" (for use with DW CS4).

1) Installed XAMPP. Used terminal to set security etc. Result - nothing works - access denied to mySQL, phpmyadmin etc.

2) Re-installed XAMPP - left out messing with terminal. Set password in mySQL for root user, added additional user - me - Steve@localhost. Can now access various bits.

3) Installed Cartweaver extension to DW. Set up database - so far so good. Cartweaver has various php setup files - can upload and view / access these. However the "Presentation" files (index.php) will not display when uploaded (or in DW live view). All I get on http://localhost/cartweaver/index.php is a big fat BLANK SCREEN!

4) I started out life as a designer not a coder PLEASE HELP ME!!!!

Thanx

Steve
angstman
 
Posts: 6
Joined: 18. August 2009 18:11

Re: Disappearing PHP Help!

Postby Wiedmann » 18. August 2009 20:31

Regarding Cartweaver:
Wrong support channel. We don't know anything about this app.

1) Installed XAMPP. Used terminal to set security etc. Result - nothing works - access denied to mySQL, phpmyadmin etc.

Which XAMPP version?

Can now access various bits.

So the servers (Apache/MySQL) can start and you can access the XAMPP demopage?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Disappearing PHP Help!

Postby angstman » 18. August 2009 23:02

Hi - no I agree the cartweaver support is as good as useless - away from machine for a few days so unsure which version but pretty sure it's the latest download.

Yep everything seems to work - xammp intro page, phpmyadmin etc plus php info.

Thing is the cartweaver presentation pages did work - then stopped working after a re-install (on attempting to set up security - which just doesn't work - "do you want to set password {ja}" yes - enter password - return - "please use xampp as user name". Enter xampp username plus password - access denied...)

Can only gain access to phpmyadmin after editing 1 of the config files - entering root password & changing "localhost" to "Localhost" - This thing is beyond my ken - would mamp be any easier?
angstman
 
Posts: 6
Joined: 18. August 2009 18:11

Re: Disappearing PHP Help!

Postby MegaChriz » 19. August 2009 09:10

It's true there were some problems with XAMPP for Mac v1.7.2, most of them on the XAMPP security program.
Last sunday a new XAMPP version was released: XAMPP for Mac v1.7.2a. I only installed it for now, but it seems the problems with the XAMPP security are fixed, except perhaps for setting the FTP password (I didn't test that yet).
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
Operating System: Mac OS X

Re: Disappearing PHP Help!

Postby angstman » 21. August 2009 19:15

Pheww! Well thanks Chriz - all my problems resolved by 1.7.2a - everything works - and my php pages are back - with one exception - still have to edit config.inc.php (Applications/XAMPP/xamppfiles/phpmyadmin/config.inc.php
from: $cfg['Servers'][$i]['password'] = '';
to$cfg['Servers'][$i]['password'] = 'password';

But other than that every-thing's peachy :lol:
angstman
 
Posts: 6
Joined: 18. August 2009 18:11


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests