xampp 1.7.2 on ppc

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

xampp 1.7.2 on ppc

Postby ttjess » 13. August 2009 23:18

I do not have an Intel mac and I'm having a problem running Xampp. Is this version not compatible with a ppc?
ttjess
 
Posts: 4
Joined: 13. August 2009 20:37

Re: xampp 1.7.2 on ppc

Postby CmdrGuard » 14. August 2009 01:24

I can confirm that XAMPP 1.7.2 isn't working on my PPC mac either. I checked the console and this is what I got:

Code: Select all
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] dyld: Library not loaded: @execu
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] table_path/../Frameworks/PlugIn.
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] framework/Versions/A/PlugIn
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804]   Re
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] ferenced from: /Applications/XAM
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] PP/XAMPP Control.app/Contents/Ma
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] cOS/XAMPP Control
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804]   Reason: no s
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] uitable image found.  Did find:
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804]  /Applications/XAMPP/XAMPP Contr
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] ol.app/Contents/MacOS/../Framewo
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] rks/PlugIn.framework/Versions/A/
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] PlugIn: mach-o, but wrong archit
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] ecture
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804]  /Applications/XAMPP/XAMP
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] P Control.app/Contents/MacOS/../
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] Frameworks/PlugIn.framework/Vers
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804] ions/A/PlugIn: mach-o, but wrong
8/13/09 8:06:16 PM [0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804]  architecture
8/13/09 8:06:16 PM com.apple.launchd[113] ([0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804]) Exited abnormally: Trace/BPT trap
8/13/09 8:06:16 PM com.apple.launchd[113] ([0x0-0x12a12a].org.apachefriends.XAMPP_Control[2804]) Exited abnormally: Trace/BPT trap


The part that I feel is most relevant is:

dyld: Library not loaded: @executable_path/../Frameworks/PlugIn.framework/Versions/A/PlugIn Referenced from: /Applications/XAMPP/XAMPP Control.app/Contents/MacOS/XAMPP Control Reason: no suitable image found. Did find:
/Applications/XAMPP/XAMPP Control.app/Contents/MacOS/../Frameworks/PlugIn.framework/Versions/A/
PlugIn: mach-o, but wrong architecture


So it looks like some dynamic library that is being referenced is only for intel machines and not PPC.

Perhaps this version of XAMPP fails to include a ppc version of some library?
CmdrGuard
 
Posts: 2
Joined: 14. August 2009 01:12

Re: xampp 1.7.2 on ppc

Postby CmdrGuard » 14. August 2009 03:02

Yup. The file at
/Applications/XAMPP/XAMPP Control.app/Contents/Frameworks/PlugIn.framework/Versions/A/Plugin

is indeed an intel file and not universal.

There's your problem.

Looks like this needs to be replaced with a ppc version.
CmdrGuard
 
Posts: 2
Joined: 14. August 2009 01:12

Re: xampp 1.7.2 on ppc

Postby MegaChriz » 14. August 2009 12:51

I've reported this issue to kleinweby and heard that he's working on it to fix this issue.
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
Operating System: Mac OS X

Re: xampp 1.7.2 on ppc

Postby ttjess » 14. August 2009 14:53

I just installed version 0.7.4 and everything is working fine. EXCEPT I cannot access it from my pc. I've tried a million times and it just won't work. I turned off windows sharing, file sharing, every kind of sharing in the control panel. Still can't access it. I put in http://10.0.0.115/xampp/ and it won't work. I'm on my work network and am just trying to set up an intranet site for internal use only. I've also put read/write permissions on the entire xampp folder. Am I missing something? This is very frustrating. If I can't access it, then I know the users won't be able to and it defeats the whole purpose of having the intranet!
ttjess
 
Posts: 4
Joined: 13. August 2009 20:37

Re: xampp 1.7.2 on ppc

Postby python_boot » 12. November 2009 07:15

MegaChriz wrote:I've reported this issue to kleinweby and heard that he's working on it to fix this issue.


In the meantime, is there a viable workaround? Is the XAMPP Control Panel required for it to function in OS X, or can each of the components be started individually from the command line?

I was able to start Apache and MySQL, but I was not able to get PHP running; what am I missing?
python_boot
 
Posts: 1
Joined: 12. November 2009 07:11

Re: xampp 1.7.2 on ppc

Postby MegaChriz » 13. November 2009 14:29

Most of the issues in XAMPP 1.7.2 I had discovered were fixed in XAMPP for Mac v1.7.2a, so you better install that version if you are still using XAMPP for Mac v1.7.2.

The XAMPP Control Panel isn't required to work with XAMPP. You can also start XAMPP via the command line:
1. Open Terminal
2. Type
Code: Select all
sudo su

3. Type the password of the administrator account of your Mac (you don't see an indication that you're typing your password)
4. Type
Code: Select all
/Applications/XAMPP/xamppfiles/xampp start
and XAMPP will be started.
If you only type '/Applications/XAMPP/xamppfiles/xampp' then you will get to know which options you have for this program.

If you have issues with starting XAMPP, check if you have accidently turned the webserver on that came with Mac OS X. Go to System Preferences -> Share and look for 'Personal Webserver'. If it is turned on, then turn it off and try again to start XAMPP.
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
Operating System: Mac OS X


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest