crypt error while running `xammp security`

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

crypt error while running `xammp security`

Postby mariusvw » 13. August 2009 21:40

Error:
Code: Select all
/Applications/XAMPP/xamppfiles//share/xampp/xampplib: line 136: /Applications/XAMPP/xamppfiles//share/lampp/crypt: No such file or directory
cp: /Applications/XAMPP/xamppfiles//phpsqliteadmin/.htaccess: No such file or directory
chmod: /Applications/XAMPP/xamppfiles//phpsqliteadmin/.htaccess: No such file or directory


Possible cause of crypt problem:
XAMPP/xamppfiles/share/xampp/xampplib:136

Double slash problem:
XAMPP/xamppfiles/xampp:59

If I can be of any service with this, just let me know :)

~~~ EDIT ~~~

Solution (might not be final):
Edit XAMPP/xamppfiles/share/xampp/xampplib, goto line 136.
Change:
Code: Select all
$XAMPP_ROOT/share/lampp/crypt "$a"

To:
Code: Select all
$XAMPP_ROOT/share/xampp/crypt "$a"


Edit XAMPP/xamppfiles/xampp, goto line 59.
Change:
Code: Select all
XAMPP_ROOT="/Applications/XAMPP/xamppfiles/"

To:
Code: Select all
XAMPP_ROOT="/Applications/XAMPP/xamppfiles"
Last edited by mariusvw on 16. August 2009 11:53, edited 2 times in total.
Marius van Witzenburg
http://mariusvw.com
mariusvw
 
Posts: 6
Joined: 13. August 2009 20:53
Location: The Netherlands

Re: crypt error while running `xammp security`

Postby jRod » 16. August 2009 11:43

Hi

I get the above error, any suggestions as to what I can do about it?

Thanks in advance
jRod
 
Posts: 4
Joined: 16. August 2009 11:40

Re: crypt error while running `xammp security`

Postby mariusvw » 16. August 2009 11:53

I added a possible solution into the first posting.
Marius van Witzenburg
http://mariusvw.com
mariusvw
 
Posts: 6
Joined: 13. August 2009 20:53
Location: The Netherlands

Re: crypt error while running `xammp security`

Postby mariusvw » 16. August 2009 12:21

Hmm, after fixing that I get:
Code: Select all
/Applications/XAMPP/xamppfiles/share/xampp/xampplib: /Applications/XAMPP/xamppfiles/share/xampp/crypt: /opt/lampp/bin/php: bad interpreter: No such file or directory


The following is just my opinion, but isn't it better to call the php scripts on the following way?
Code: Select all
php filename.php

That prevents problems with setting paths...
Marius van Witzenburg
http://mariusvw.com
mariusvw
 
Posts: 6
Joined: 13. August 2009 20:53
Location: The Netherlands

Re: crypt error while running `xammp security`

Postby jRod » 16. August 2009 14:37

Hi,

figured out how to make the changes you suggested and now get the same error as you.

Sorry, I don't quite understand the bit about calling php scripts please explain if possible

p.s. thanks for any help or suggestions
jRod
 
Posts: 4
Joined: 16. August 2009 11:40

Re: crypt error while running `xammp security`

Postby mariusvw » 16. August 2009 18:41

To solve it open:

/Applications/XAMPP/xamppfiles/share/xampp/crypt

On the first line there is a path to /opt/....

Change that into:

Code: Select all
#!/Applications/XAMPP/xamppfiles/bin/php -q
Marius van Witzenburg
http://mariusvw.com
mariusvw
 
Posts: 6
Joined: 13. August 2009 20:53
Location: The Netherlands

Re: crypt error while running `xammp security`

Postby jRod » 16. August 2009 20:34

I applied the three changes and it now works perfectly.

and I learned a bit of LINUX in the process

Thanks again
jRod
 
Posts: 4
Joined: 16. August 2009 11:40


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 5 guests