.htaccess files for Zend (editing httpd.conf doesn't work)

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

.htaccess files for Zend (editing httpd.conf doesn't work)

Postby Qaaolchoura » 09. August 2009 04:30

OK, I have an uncanny knack for asking stupid questions, so I have some trepidation about asking this, but I've spent about 5-6 hours on this one problem, and Google's been no help.

After installing the Zend framework, both the Zend website and the books I'm using said to set up a .htaccess file. They all differ slightly on what to include, but the main point of agreement seems to be that Zend works best without the long ".php?var1=x&var2=y" thing that php normally uses, and replace it with Wikimedia-style urls. The example from my book is:
Code: Select all
RewriteEngine on
RewriteRule !\.(js|gif|jpg|png|css)$ index.php

The problem is that when I have a .htaccess file, it interferes
Code: Select all
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, you@example.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

The first time I tried this, there was a problem with the .htaccess file in the error log.

So I Googled it, opened the two httpd.config files in xampp. "LoadModule rewrite_module modules/mod_rewrite.so" was already uncommented somehow in both, so I changed AllowOverwrite from "None" to "All."

I still had no luck, an figured that maybe the version of XAMPP I was using was deprecated, so I deleted it an installed it again, still nothing.

Now I get the same error message when I have a .htaccess file, but the error log comes up blank.

And to be clear on another detail that came up on these forums: I'm using JEdit, which has Unix linebreaks as the default.

Does anybody have any idea what my problem is? It seems suspicious that "LoadModule &c" was already uncommented, so maybe the advice I found on fixing the .htaccess problem for Windows doesn't work on Mac (though if Apache is supposed to be platform neutral, that seems a bit strange).

I'd greatly appreciate any advice on this matter.
Thanks,
~Q
Qaaolchoura
 
Posts: 1
Joined: 09. August 2009 04:02

Re: .htaccess files for Zend (editing httpd.conf doesn't work)

Postby Wiedmann » 09. August 2009 09:01

More information about this error may be available in the server error log.

Just read the error log, and you know what is raising this error 500.
(we also can't know this, without reading the error log)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest