Web pages don't show

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Web pages don't show

Postby Adriaanh » 03. August 2009 16:11

My web pages show on the host computer (both when addressed by localhost and by the web address), but not on any computer trying to reach them from the web. I thought this might be a permissions problem. All files are now set to 0755, but I've also experimented with 0777, but that doesn't seem to help. I must admit that permissions baffle me. I cannot seem to see a correspondence between the Mac OS info window and this Octal Mode representation. Also, Mac OS says I am the owner, while Fugu says the owner is 'nobody', which also runs Apache. Could this be where the problem lies (for example, the fact that the 'real' htdocs has a different owner than the alias in the XAMPP folder in Applications), or is it something different, and if so, what? (I am not very good with terminal commands, etc.)

Thanks a lot,

Adriaanh
Last edited by Adriaanh on 03. August 2009 16:21, edited 1 time in total.
Adriaanh
 
Posts: 2
Joined: 03. August 2009 15:59

Re: Web pages don't show

Postby Wiedmann » 03. August 2009 16:18

I thought this might be a permissions problem.

No.

My web pages show on the host computer (both when addressed by localhost and by the web address), but not on any computer trying to reach them from the web.

- Wrong firewall configuration
- Wrong router configuration
- ISP doeas not allow these connections
- the others are using a wrong IP
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Web pages don't show

Postby Adriaanh » 03. August 2009 16:23

If it's a 'Wrong firewall configuration', how/where do I check?

Thanks,

Adriaanh

PS I reworded my original post to suggest another possible problem.
Adriaanh
 
Posts: 2
Joined: 03. August 2009 15:59

Re: Web pages don't show

Postby Wiedmann » 03. August 2009 16:25

If it's a 'Wrong firewall configuration', how/where do I check?

I don't know anything OS X. But if there is a firewall, there shojld be something to configure it. Just allow connections to port 80.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Web pages don't show

Postby MegaChriz » 04. August 2009 16:11

Firewall on Mac OS X:
1. Open the system preferences.
2. If you have Tiger, you need to look for the firewal settings by 'Share', if you have Leopard you need to look by 'security'.

Personally I think it's the router. I also have this problem, but it still exists when I turn the firewall off.
I haven't figured out yet how to change the router configuration (the router is not mine).

I only managed to show my webpages in the (home)network the computer is in.
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
Operating System: Mac OS X


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 5 guests