No Images on Other Computer Browsers

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

No Images on Other Computer Browsers

Postby JackPK » 19. July 2009 21:56

Hi, I am using Opencart which I setup and installed in the htdocs folder and runs fine on the host mac.
I put in the ip address of localhost on a PC with firefox and all the text show but no images.
Can you help please !
Thanks !
JackPK
 
Posts: 3
Joined: 19. July 2009 21:52

Re: No Images on Other Computer Browsers

Postby caltuna » 19. July 2009 23:36

Is this PC running on your local network or is this on some server somewhere?

On the PC, take a look and see if you can find out what the URL is of the images that don't show. I assume you get a place-holder icon of some sort? Maybe look at the "source" code on the PC and maybe that will help.

This is most likely some kind of addressing problem and you will have to change something in the cart on how it generates the URL for the images.
I'm sure it is looking in some folder that does not exist or is not being referenced correctly. Are you using absolute addressing or virtual (I think that's what they call it when you don't use a full url in the html ... http://xxxx.com/some-image.jpg

Al
caltuna
 
Posts: 111
Joined: 05. May 2009 16:35

Re: No Images on Other Computer Browsers

Postby JackPK » 20. July 2009 19:48

Hi Al,
Thanks for the help, it worked a treat.
The problem was the url in config.php and that it wanted the full address and not just localhost.
Thanks Again.
JackPK
 
Posts: 3
Joined: 19. July 2009 21:52


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests