Starting XAMPP not working

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Starting XAMPP not working

Postby digitalterry » 15. July 2009 02:23

When I try to start the Apache, it does not load. A blank dialog pops up with an exclamation mark. In the console, I see:

14/07/09 9:15:12 PM XAMPP Control[144] Directory for pid does not exits!


I tried searching for this error in Google and did not find anything specific. I am not sure what I am doing wrong.

Any suggestions?
digitalterry
 
Posts: 3
Joined: 15. July 2009 02:19

Re: Starting XAMPP not working

Postby caltuna » 15. July 2009 04:08

Probably permissions. Use GetInfo on all the folders/files in the XAMPP directory and set them to read-write for everyone.
caltuna
 
Posts: 111
Joined: 05. May 2009 16:35

Re: Starting XAMPP not working

Postby digitalterry » 15. July 2009 13:46

OK, that makes sense. However, I am unable to change permissions on the XAMPP folder. When I go to the window, the padlock is greyed out even though it shows "me" as having full read-right permissions.

I went to the main Applications folder and was able to change the permissions on the top level "XAMPP for Mac OS X 1.0.1" shortcut but when I go down a level to try to change the permissions for "XAMPP", the padlock is greyed out.

Any thoughts? I am using OS X 10.5.7.

Also, is this typical behavior for an application? I didn't see instructions suggesting that this might need to be done so I am wondering if my Mac is not acting normal.

Thanks
Terry
digitalterry
 
Posts: 3
Joined: 15. July 2009 02:19

Re: Starting XAMPP not working

Postby kleinweby » 15. July 2009 15:56

digitalterry wrote:I went to the main Applications folder and was able to change the permissions on the top level "XAMPP for Mac OS X 1.0.1" shortcut but when I go down a level to try to change the permissions for "XAMPP", the padlock is greyed out.


Sounds like you're trying to start XAMPP from the DMG. First you have to copy XAMPP to /Applications/.

Greetings,
kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Re: Starting XAMPP not working

Postby digitalterry » 15. July 2009 22:20

That was it. I was misunderstanding how to "install" applications!

Terry
digitalterry
 
Posts: 3
Joined: 15. July 2009 02:19


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests