"localhost" error?

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

"localhost" error?

Postby Dr. Strange » 01. July 2009 02:39

hi there,

when i first install xampp, i start all the proccesses and then when i go to test out the page, (by typing in the URL "localhost"), it comes up with a page that says:
If you can see this, it means that the installation of the Apache web server software on this system was successful. You may now add content to this directory and replace this page.

Seeing this instead of the website you expected?

This page is here because the site administrator has changed the configuration of this web server. Please contact the person responsible for maintaining this server with questions. The Apache Software Foundation, which wrote the web server software this site administrator is using, has nothing to do with maintaining this site and cannot help resolve configuration issues.

The Apache documentation has been included with this distribution.

You are free to use the image below on an Apache-powered web server. Thanks for using Apache!


but when i type in 127.0.0.1, or my IP address (192.***.*.***)i get the proper XAMPP page. i also have xampp for windows, and that works without a problem.
i would like to be able to fix this, because i HATE having to type in the address every time.

what have i done wrong???
User avatar
Dr. Strange
 
Posts: 3
Joined: 01. July 2009 02:27

Re: "localhost" error?

Postby kleinweby » 01. July 2009 10:47

Hey...

This looks like WebSharing is still on. Got to the System preferences and turn Web Sharing in the Sharing panel off.
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Re: "localhost" error?

Postby Nobbie » 01. July 2009 10:48

Looks like you screwed up your Mac, as there was already installed an Apacher Server.
Nobbie
 
Posts: 8762
Joined: 09. March 2008 13:04

Re: "localhost" error?

Postby Dr. Strange » 01. July 2009 23:13

thanks for the quick response guys...

@kleinweby Thanks, i don't think i have checked there...

@Nobbie Hey, i don't know if there was already something on there, how would i find out?

thanks, i will try these options soon
User avatar
Dr. Strange
 
Posts: 3
Joined: 01. July 2009 02:27

Re: "localhost" error?

Postby mgph » 16. July 2009 08:46

thanks, it saved my life too. But when I type in just http://localhost, it still show the same page mentioned above, only when I type in 127.0.0.1(like automatic redirect to xampp index) or localhost/xampp, the proper xampp page appears. How can I change so that I need to type only "localhost" ?

thanks in advance
mgph
 
Posts: 2
Joined: 16. July 2009 08:42

Re: "localhost" error?

Postby caltuna » 16. July 2009 21:51

Go to Terminal and enter:

cat /etc/hosts

do you get this:

Code: Select all
##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1       localhost
255.255.255.255 broadcasthost
::1             localhost
caltuna
 
Posts: 111
Joined: 05. May 2009 16:35

Re: "localhost" error?

Postby mgph » 18. July 2009 07:19

caltuna wrote:Go to Terminal and enter:

cat /etc/hosts

do you get this:

Code: Select all
##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1       localhost
255.255.255.255 broadcasthost
::1             localhost


ya, my bad I forgot to delete some texts there. Now I could solve it out and thanks alot !
mgph
 
Posts: 2
Joined: 16. July 2009 08:42


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 5 guests