Strange problems with starting Apache, MySQL, and FTP

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Strange problems with starting Apache, MySQL, and FTP

Postby Dariusra » 10. June 2009 18:42

Im starting a new topic since I have no idea how I would go about searching for this. It is to obscure for me to understand.

The problem:
If I am connected to a wireless router(that is connected to the internet) I am not able to start
Apache or FTP from the Xamp control panel but I am able to start MySQL.

When I try to start Apache or FTP I get a pop up box with no text or error message in it and an OK button.

If I turn my wireless connection off I am again able to start Apache and FTP but MySQL takes an unusually
long time to start and sometimes just hangs in the "starting" position.

What I have tried:

Restarting: The same thing happens even after restarting

Installing a separate instance of Xamp: The same symptoms in the same situations occur which rules out something funky
with the php.ini file or similar.

What I have observed:

Even after freshly restarting Ive noticed that 5-6 instances of httpd are running. All identical processes.


At this point it is just a bit of a pain since Ive found the work around(disconnecting from the internet) but something
is not right. This just started over night and other then installing some components, modules, plugins, etc into the
Joomla! site Im building I made not deliberate changes to anything.

Any thoughts? The pop up box's with nothing in them is the most confusing part about all this
Dariusra
 
Posts: 2
Joined: 10. June 2009 18:28

Re: Strange problems with starting Apache, MySQL, and FTP

Postby caltuna » 10. June 2009 18:48

My guess is that something or someone turned on Personal Web Sharing. Go to System Prefs, Sharing, and make sure the box for Web Sharing is not checked. If you turn it off you may have to re-start to get it to "take" but I'm not sure.

The only other thing I'd check is the "port blocking" feature of your router. I believe XAMPP listens on port 80 and maybe the router has it blocked?

Al
http://www.insol123.com
caltuna
 
Posts: 111
Joined: 05. May 2009 16:35

Re: Strange problems with starting Apache, MySQL, and FTP

Postby Dariusra » 11. June 2009 19:50

Thanks for the response. As the built in OSX web server was not turned on and this problem I outlined seems to only happen with one particular wireless access
point at a cafe Im thinking that your second possibility is dead on:

quote:
"The only other thing I'd check is the "port blocking" feature of your router. I believe XAMPP listens on port 80 and maybe the router has it blocked?"\

The wireless router at that cafe probably had port 80 blocked.

Im a little wiser about how intelligent a web server is and what it looks for. Thank you :)
Dariusra
 
Posts: 2
Joined: 10. June 2009 18:28


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests