XAMPP Suddenly no longer works. "Seeing this instead of the"

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

XAMPP Suddenly no longer works. "Seeing this instead of the"

Postby strujillo.jr » 13. May 2009 18:31

Ok so I bought my Mac about Three months ago. I installed XAMPP and it worked amazingly well! Then I go on the other day to start working on my Website but, when I started up XAMPP through the terminal and went into localhost it says
Code: Select all

If you can see this, it means that the installation of the Apache web server software on this system was successful. You may now add content to this directory and replace this page.

[b]Seeing this instead of the website you expected?
[/b]
This page is here because the site administrator has changed the configuration of this web server. Please contact the person responsible for maintaining this server with questions. The Apache Software Foundation, which wrote the web server software this site administrator is using, has nothing to do with maintaining this site and cannot help resolve configuration issues.

The Apache documentation has been included with this distribution.

You are free to use the image below on an Apache-powered web server. Thanks for using Apache!


why is this? I never changed no settings! I unistalled XAMPP and reinstalled it, but it still wont work. Even when I dont start the server this page is still up. Whats wrong? I even installed MAMPP and still nothing worked. Even when I completely removed BOTH apps, this page was still up. Whats going on? I really need to work on this stuff but no matter what I do nothing works. Do you have any idea.
strujillo.jr
 
Posts: 2
Joined: 13. May 2009 18:25

Re: XAMPP Suddenly no longer works. "Seeing this instead of the"

Postby caltuna » 14. May 2009 01:07

My bet is that somehow the apache server that comes with OS X got turned on. Look in System Prefs, Sharing, and make sure Personal Web is not checked.

You say you started XAMPP from terminal? Why? Why not from the XAMMP control?

One other question. Did you do the new Leopard update that came out a few days ago? That might have broken XAMPP by turning on Personal Web Sharing.
caltuna
 
Posts: 111
Joined: 05. May 2009 16:35

Re: XAMPP Suddenly no longer works. "Seeing this instead of the"

Postby strujillo.jr » 14. May 2009 02:06

Wow, thank you so much. My XAMPP was also broken, but it was that damn Server that go turned on! Your amazing! :mrgreen:
strujillo.jr
 
Posts: 2
Joined: 13. May 2009 18:25

Re: XAMPP Suddenly no longer works. "Seeing this instead of the"

Postby caltuna » 14. May 2009 05:50

strujillo.jr wrote:Wow, thank you so much. My XAMPP was also broken, but it was that damn Server that go turned on! Your amazing! :mrgreen:


Not amazing at all. I've just been working with various stacks on OS X for a while and this problem is common. There is some gremlin in the basement of OS X that comes out every so often and turns on Personal Web Sharing which simply "hoses" any attempt of run a non-Apple version of Apache.

Al
http://www.insol123.com
caltuna
 
Posts: 111
Joined: 05. May 2009 16:35


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 5 guests