is XAMPP compatible with OS X v10.5.6 Leopard?

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

is XAMPP compatible with OS X v10.5.6 Leopard?

Postby slam38 » 11. May 2009 13:16

I have an Mac Book Pro v10.5.6 OS X Leopard.

I have been trying to set up PHP5. At first I tried to download Mark Liyanage's PHP5 entropy package but it was not compatible with the Leopard operating system.

I was then advised to enable the pre-installed PHP5 in my Mac Book instead, which I did successfully, except the GD extension was not enabled.

I was then advised to download and install Xcode 3.1.2, X11 SDK and the latest version of X11 in order to start the process of enabling PHP5. I know nothing about the developer codes and I am also aware that I will be messing around under the hood of my Mac and obviously want to proceed with caution around this.

Then it was suggested that I download and install MAMP. Because of the problems I have encountered so far after upgrading my operating system to Leopard, I want to be sure that both XAMPP and MAMP are compatible with Leopard and which version of either of these packages would be better for me.

I would also like to know if I need to disable the pre-installed PHP5 that I have enabled in order for XAMPP or MAMP to work properly without any problems?

Any help with either of these questions would be greatly appreciated as I have been trying to solve this problem for a while now and am close to tearing my hair out.


Posts: 1
Joined: 11. May 2009 12:54

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests