Problem with .htaccess file

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Problem with .htaccess file

Postby komer83 » 11. February 2009 14:36

I installed xampp insted of mamp, everything is almost working well, it is much faster (mamp was not updated for too long...), I even managed to work with my database much better.

But, I still have a problem I could not fix, the .htaccess file.

my directory works like that:
.htaccess
index.html
index.php
graphic library, SMART library etc.

I can access the index.html and its graphics, but from there I can't do nothing and get
Code: Select all
Not Found

The requested URL /index.php was not found on this server.


I can access the graphic library and files, and other files that are not in the main directory. if I put a graphic file in the main directory I get the same error.

what to do? what am I missing?

Thank you,
Omer Katzir
komer83
 
Posts: 2
Joined: 11. February 2009 14:28

Re: Problem with .htaccess file

Postby sergarbes » 14. February 2009 22:10

komer83 wrote:I installed xampp insted of mamp, everything is almost working well, it is much faster (mamp was not updated for too long...), I even managed to work with my database much better.

But, I still have a problem I could not fix, the .htaccess file.

my directory works like that:
.htaccess
index.html
index.php
graphic library, SMART library etc.

...

what to do? what am I missing?

Thank you,
Omer Katzir


Hi Omer,

I'm not sure. I've not understand well your problem.

But when I've to setup xampp to develop with Zend Framework I changed the AllowOverride Apache directive witch you can find in xampp/etc/httpd.conf from AuthConfig to All.

Hope that it helps ;)

Sergi
sergarbes
 
Posts: 4
Joined: 02. January 2009 17:03

Re: Problem with .htaccess file

Postby komer83 » 16. February 2009 11:12

done that, without changing it i could not even access the main page.

but every file in the main library cannot be accessed (beside the index.html)
komer83
 
Posts: 2
Joined: 11. February 2009 14:28

Re: Problem with .htaccess file

Postby MegaChriz » 23. February 2009 09:30

What does your .htaccess file contain?

Maybe you need to set the 'line break type' to UNIX (LI or LF). I believe that the line break type for text-editors for Mac are standard set to 'Macintosh (CR)'. With this setting I had also problems with .htaccess-files in combination with XAMPP. But when I set this to UNIX the .htaccess files worked normally for me.
MegaChriz
 
Posts: 158
Joined: 16. February 2009 15:04
Location: Amersfoort, The Netherlands
Operating System: Mac OS X


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests