XAMPP 1.0 post-install problems

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

XAMPP 1.0 post-install problems

Postby plikarish » 22. December 2008 23:23

Hello,

I have just upgraded to 1.0 and am having permissions problems. Noting that there is not a tarred/gzipped version, I downloaded the universal binary, mounted it and copied it to Applications *without* doing the sudo su, tar ... step.
I have tried starting XAMPP a variety of ways:
1.) double click on XAMPP Controller
2.) from cmdline:
sudo su
XAMP Controller

sudo su
xampp start

Regardless of the method by which I start XAMPP the following occurs. I start Apache. I browse to localhost in FF3.05. I see *not* the splash page but rather the index.php page with German selected as the language. I am an English speaker so I click on the English link and receive the following output:

Warning: fopen(lang.tmp) [function.fopen]: failed to open stream: Permission denied in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 2

Warning: fwrite(): supplied argument is not a valid stream resource in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 3

Warning: fclose(): supplied argument is not a valid stream resource in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 4

Warning: Cannot modify header information - headers already sent by (output started at /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php:2) in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 5

I get the same result from browsing to the splash screen and clicking on the en link there.

I poked around and didn't see this issue. Let me know if you have ideas thanks,

Peter
plikarish
 
Posts: 3
Joined: 22. December 2008 22:51

Re: XAMPP 1.0 post-install problems

Postby plikarish » 22. December 2008 23:33

Since it's a permissions problem, here's a ps aux|grep xampp:

***** 21366 0.3 0.0 599780 428 s001 R+ 3:30PM 0:00.00 grep xampp
root 21253 0.0 0.0 600252 796 s001 S 3:21PM 0:00.02 /bin/sh /Applications/XAMPP/xamppfiles/bin/mysqld_safe --datadir=/Applications/XAMPP/xamppfiles/var/mysql --pid-file=/Applications/XAMPP/xamppfiles/var/mysql/******-MacBook-Pro.local.pid
root 21233 0.0 0.2 98688 6812 ?? Ss 3:21PM 0:00.17 /Applications/XAMPP/xamppfiles/bin/httpd -k start -DPHP5
nobody 21353 0.0 0.0 98688 640 ?? S 3:21PM 0:00.00 /Applications/XAMPP/xamppfiles/bin/httpd -k start -DPHP5
nobody 21352 0.0 0.0 98688 640 ?? S 3:21PM 0:00.00 /Applications/XAMPP/xamppfiles/bin/httpd -k start -DPHP5
nobody 21351 0.0 0.0 98688 640 ?? S 3:21PM 0:00.00 /Applications/XAMPP/xamppfiles/bin/httpd -k start -DPHP5
nobody 21350 0.0 0.0 98688 640 ?? S 3:21PM 0:00.00 /Applications/XAMPP/xamppfiles/bin/httpd -k start -DPHP5
nobody 21349 0.0 0.0 98688 640 ?? S 3:21PM 0:00.00 /Applications/XAMPP/xamppfiles/bin/httpd -k start -DPHP5
nobody 21348 0.0 0.1 98688 4140 ?? S 3:21PM 0:00.01 /Applications/XAMPP/xamppfiles/bin/httpd -k start -DPHP5
nobody 21347 0.0 0.0 96776 748 ?? S 3:21PM 0:00.00 /Applications/XAMPP/xamppfiles/bin/httpd -k start -DPHP5
nobody 21346 0.0 0.3 103780 12932 s001 S 3:21PM 0:00.37 /Applications/XAMPP/xamppfiles/sbin/mysqld --basedir=/Applications/XAMPP/xamppfiles --datadir=/Applications/XAMPP/xamppfiles/var/mysql --user=nobody --log-error=/Applications/XAMPP/xamppfiles/var/mysql/******-MacBook-Pro.local.err --pid-file=/Applications/XAMPP/xamppfiles/var/mysql/******-MacBook-Pro.local.pid --socket=/Applications/XAMPP/xamppfiles/var/mysql/mysql.sock --port=3306
plikarish
 
Posts: 3
Joined: 22. December 2008 22:51

Re: XAMPP 1.0 post-install problems

Postby plikarish » 23. December 2008 02:49

sudo chown nobody:nobody /Applications/XAMPP/xamppfiles/htdocs/lang.tmp
seems to have fixed it.
plikarish
 
Posts: 3
Joined: 22. December 2008 22:51

Re: XAMPP 1.0 post-install problems

Postby kleinweby » 23. December 2008 11:41

hello,

thanks for reporting this issue.

I'll fix this in the nex release of XAMPP for Mac OS X.

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests