Problem with Localhost - file downloads instead

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Problem with Localhost - file downloads instead

Postby Xenophon » 22. December 2008 14:17

Dear Xampp friends,

I've just downloaded and installed the new Xampp package available for OSX. Just trying to keep up to date. But I've a problem when I type 'localhost' in Safari or Firefox. Instead of parsing index.php, I get the 'download' dialogue box from Safari or Firefox. What's going wrong?
Xenophon
 
Posts: 2
Joined: 22. December 2008 14:12

Re: Problem with Localhost - file downloads instead

Postby calvin1984 » 22. December 2008 19:20

Same problem here, I removed the previous version of XAMPP and installed the latest one. Was able to load the index.php file fine on the previous version but not the latest one.
calvin1984
 
Posts: 1
Joined: 22. December 2008 19:18

Re: Problem with Localhost - file downloads instead

Postby hudson_z » 23. December 2008 19:10

I have the same issue.
It seams to me that php just isn't running.
I tried renaming php files .html and then the browser reads the html but doesn't process any php you put in there.
hudson_z
 
Posts: 1
Joined: 23. December 2008 19:06

Re: Problem with Localhost - file downloads instead

Postby Wiedmann » 23. December 2008 19:41

Which OS X version are you using? AFAIK there is a problem with 10.4 and XAMPP 1.7.0.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Problem with Localhost - file downloads instead

Postby qgriffith » 05. January 2009 01:19

For whatever reason if you go to 127.0.0.1 it will work or if you got to your hostname .local for example if your computer was named Fred you would go to fred.local and it will work. Haven't figured out why though.
qgriffith
 
Posts: 1
Joined: 05. January 2009 01:18

Re: Problem with Localhost - file downloads instead

Postby Xenophon » 06. January 2009 09:49

At work I use 10.5.5 with the latest Xampp, at home same problem with 10.5.6.

So how do I enable PHP again then?
Xenophon
 
Posts: 2
Joined: 22. December 2008 14:12


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 7 guests