Install php_zip extension

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Install php_zip extension

Postby dw_Scott » 09. November 2008 22:00


Could anyone tell me how to enable zip extensions with XAMPP on OSX

I understand how to do it on a windows machine but am having trouble with the OSX version.

Posts: 1
Joined: 09. November 2008 21:47

Postby glitzi85 » 10. November 2008 14:28

If you really want the zip extension yould would have to recompile PHP if it is not included yet. Maybe it would be easier to use the PECL Extension.

User avatar
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby vincentc » 20. November 2008 10:23


I have the same problem. The zip is not activated, but when i look at the installation, the directive --with-zip was defined.

I use the version 0.7.4 of Xampp for Mac. With the previous release, 0.7.3, i haven't the problem "ZipArchive not found".

I try to install the pecl package via "pecl install zip" but fails with something like "autoconf not found" and PHPize failed.

I think i will try to reinstall 0.7.3 soon to verify the problem.

Is there anyone who can help us ? Is this a bug from Xampp 0.7.4 ? Please help.
Posts: 7
Joined: 30. October 2008 11:03

Re: Install php_zip extension

Postby vincentc » 06. December 2008 15:48

I have some answers on the net. You must install:

- XCode from Apple with the default installation. The program will install autoconf, autoheader... in "/usr/bin".
- Xampp developper package with command line "tar xvfpz xampp-macosx-0.7.4-dev.tar.gz -C /Applications/xampp"

After that, all errors gone except one : "ERROR: `phpize' failed"

Here is what i try to install a pecl package:

Code: Select all
sudo sh /Applications/xampp/xamppfiles/bin/pecl install tidy
downloading tidy-1.2.tgz ...
Starting to download tidy-1.2.tgz (9,602 bytes)
.....done: 9,602 bytes
3 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
ERROR: `phpize' failed

Anyone has an idea to help me succeeded to install pecl extensions ? Please, help !
Posts: 7
Joined: 30. October 2008 11:03

Re: Install php_zip extension

Postby vincentc » 07. December 2008 18:19


After 3 days of trying, installing, reinstalling, googling...

I've try this one post : viewtopic.php?t=31294 with the sources of php 5.2.7. The timeS i try it doesn't worked. I've install macports after that, and try many other things that did'nt work too. I finally try a last one already with the post and it succeeded. And i don't know why...

Here is my command lines to compile PHP :

'./configure' '--prefix=/Applications/xampp/xamppfiles' '--program-suffix=-5.2.7' '--libdir=/Applications/xampp/xamppfiles/lib/php/php5' '--includedir=/Applications/xampp/xamppfiles/include/php/php5' '--with-apxs2=/Applications/xampp/xamppfiles/bin/apxs' '--with-config-file-path=/Applications/xampp/etc' '--with-mysql=/Applications/xampp/xamppfiles' '--disable-debug' '--enable-bcmath' '--enable-calendar' '--enable-ctype' '--enable-dbase' '--enable-discard-path' '--enable-exif' '--enable-filepro' '--enable-force-cgi-redirect' '--enable-ftp' '--enable-gd-imgstrttf' '--enable-gd-native-ttf' '--with-ttf' '--enable-magic-quotes' '--enable-memory-limit' '--enable-safe-mode' '--enable-shmop' '--enable-sigchild' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--enable-wddx' '--enable-yp' '--with-ftp' '--with-ncurses=/Applications/xampp/xamppfiles' '--with-gdbm=/Applications/xampp/xamppfiles' '--with-jpeg-dir=/Applications/xampp/xamppfiles' '--with-png-dir=/Applications/xampp/xamppfiles' '--with-freetype-dir=/Applications/xampp/xamppfiles' '--without-xpm' '--with-zlib=yes' '--with-zlib-dir=/Applications/xampp/xamppfiles' '--with-openssl=/Applications/xampp/xamppfiles' '--with-expat-dir=/Applications/xampp/xamppfiles' '--enable-xslt=/Applications/xampp/xamppfiles' '--with-xsl=/Applications/xampp/xamppfiles' '--enable-dom' '--with-ldap=/Applications/xampp/xamppfiles' '--with-gd=/Applications/xampp/xamppfiles' '--with-mysql-sock=/Applications/xampp/xamppfiles/var/mysql/mysql.sock' '--with-mcrypt=/Applications/xampp/xamppfiles' '--with-mhash=/Applications/xampp/xamppfiles' '--enable-sockets' '--with-curl=/Applications/xampp/xamppfiles' '--enable-mbregex' '--enable-zend-multibyte' '--enable-zip' '--with-libxml-dir=/Applications/xampp/xamppfiles' '--enable-soap' '--enable-pcntl' '--enable-dbx' '--with-mysqli=/Applications/xampp/xamppfiles/bin/mysql_config' '--with-bz2=/Applications/xampp/xamppfiles' '--with-ming=shared,/Applications/xampp/xamppfiles' '--with-pear=/Applications/xampp/xamppfiles/lib/php/pear' '--with-mssql=/Applications/xampp/xamppfiles' '--with-imap-dir=/Applications/xampp/xamppfiles' '--with-imap=/Applications/xampp/xamppfiles' '--enable-mbstring=all' '--with-pgsql=shared,/Applications/xampp/xamppfiles' '--with-gettext=/Applications/xampp/xamppfiles' '--with-tidy' '--with-iconv=/Applications/xampp/xamppfiles'


sudo make install

I've not install pdo. But you can test it with '--with-pdo-mysql=/Applications/xampp/xamppfiles'.
Good luck for you
Posts: 7
Joined: 30. October 2008 11:03

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 7 guests