phpMyAdmin import error

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

phpMyAdmin import error

Postby bartolo » 03. November 2008 21:55

I am having troubles importing a csv file (from Mac desktop) into a local test db created with xampp.

I keep getting this error: No data was received to import. Either no file name was submitted, or the file size exceeded the maximum size permitted by your PHP configuration. See FAQ 1.16.

Re FAQ 1.16:
1) The csv file is only 64k and has been verified to work (*see below)
2) Since the error process is very short, it's not a timeout problem
3) upload_max_filesize, memory_limit & post_max_size in the php.ini file are all properly set
4) the additional workarounds do not apply since the file is not over size and I am not dealing with an ISP issue

*I have been able to successfully import the file into a demo MySQL db offered at http://www.phpmyadmin.net/home_page/demos.php.

Any and all info would be greatly appreciated.

Thanks
bartolo
 
Posts: 10
Joined: 06. October 2008 22:41
Location: Los Angeles

I found an answer.

Postby bartolo » 05. November 2008 00:33

I found the solution to my import problem. It was buried in another posting dealing with a problem that had nothing to do with my situation. See XAMPP and Leopard - 2007-11-30. I found it by searching for "import" in XAMPP for Mac OS X.

It was an xampp default setting for the php.ini file. For some reason, xampp has chosen to set "upload_tmp_dir" to being commented out. Hence, there was no temp holding area for the file I was attempting to import.

By changing the parameters of "upload_tmp_dir" in the php.ini file -
1) by uncommenting it and
2) setting it to "/tmp"
everything is working fine.
bartolo
 
Posts: 10
Joined: 06. October 2008 22:41
Location: Los Angeles

Re: phpMyAdmin import error

Postby kateland » 12. April 2013 02:03

Hi all, I too was trying to import a txt CSV file into an existing database and got the error:

No data was received to import. Either no file name was submitted, or the file size exceeded the maximum size permitted by your PHP configuration. See FAQ 1.16.


In phpmyadmin, it was stating my max filesize was 8,192KiB but I had changed my upload_max_filesize to 80MB. See the problem? It should be 80M, not 80MB. Also, I've read that post_max_size and memory_limit need to be larger than upload_max_filesize. My settings in the end were:

upload_max_filesize: 80M
post_max_size: 128M
memory_limit: 128M
max_execution_time: 700

I restarted MySQL and Apache, reloaded the phpMyAdmin page, and successfully imported my data.
kateland
 
Posts: 4
Joined: 12. April 2013 01:19
XAMPP Version: 5.6.3
Operating System: Win 7 64 bit


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests