BUG?: AllowOverride setting differs from LAMPP and WAMPP

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

BUG?: AllowOverride setting differs from LAMPP and WAMPP

Postby dcam » 26. August 2008 02:40

I couldn't find any links to bug trackers from the main site. If there is a different procedure for reporting bugs, please let me know.

The Linux and Windows versions have the equivalent of (in pseudo-.conf):
<Directory "...htdocs">
AllowOverride All

But the Macintosh version has:
<Directory "...htdocs">
AllowOverride AuthConfig

This means Drupal works out of the box with LAMPP and WAMPP, but not with MAMPP. Probably other applications are affected too. See this thread:


(I have posted there as davcamer)
Posts: 1
Joined: 26. August 2008 02:34

Postby glitzi85 » 29. August 2008 18:17

XAMPP is not designed to work directly with every Application in the whole wide world. If you want to run Drupal on XAMPP for Mac, just change the AuthConfig to All.

XAMPP is a development system, i think the developers assume that you are intent to learn about the system you are using. Otherwise rent webspace where you can run Drupal and host it there.

It's not bug, it's a feature ;-)

User avatar
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests