firefox/safari issue with localhost -- mac leopard

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

firefox/safari issue with localhost -- mac leopard

Postby adamon » 25. August 2008 20:26

Hello.

I have upgraded to the latest XAMPP running Leopard. When I try to go to localhost on firefox 3.0.1 and safari 3.1.2 I get the apache start up page that came with leopard. When I run an older version of netscape I get the XAMPP start up page. How do I fix this?

To make things worse, my laptop is configured the same way and when I upgraded, all the browsers showed the XAMPP startup page.

Any help with this issue would be greatly appreciated.

Regards,
Rob
adamon
 
Posts: 15
Joined: 19. February 2008 19:11

Postby Nobbie » 25. August 2008 21:42

Clear all browser caches and try again.
Nobbie
 
Posts: 8778
Joined: 09. March 2008 13:04

Postby adamon » 25. August 2008 22:49

I cleared the browsers with no luck. Are there issues with firefox and safari?
Or another work-around?
adamon
 
Posts: 15
Joined: 19. February 2008 19:11

Postby jmdirc » 26. August 2008 03:46

I don't have Leopard so I'm guessing at your problem here, I posted it in another thread but they never responded - so I'm not sure it works.

try this

go to:
/Applications/xampp/etc/extra/httpd-vhosts.conf

add:
<VirtualHost *:80>
DocumentRoot "/Applications/xampp/htdocs"
ServerName localhost
<Directory />
Options FollowSymLinks
AllowOverride All
</Directory>
</VirtualHost>
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Postby adamon » 26. August 2008 04:16

I tried that also. Do I have to replace anything in the file with that code or just copy it at the end of the file?

Thanks for all the help so far!
adamon
 
Posts: 15
Joined: 19. February 2008 19:11

Postby jmdirc » 26. August 2008 12:30

Find the similar line and replace. In stead of deleting the code already there - just comment it out. That way if this doesn't work, you won't have to guess what it used to say.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Postby adamon » 26. August 2008 16:48

Here is the code after I comented out and made changes:

<VirtualHost *:80>
ServerAdmin webmaster@dummy-host.example.com
#DocumentRoot "/Applications/xampp/xamppfiles/docs/dummy-host.example.com"
#ServerName dummy-host.example.com
DocumentRoot "/Applications/xampp/htdocs"
ServerName localhost
<Directory />
Options FollowSymLinks
AllowOverride All
</Directory>

ServerAlias www.dummy-host.example.com
ErrorLog "logs/dummy-host.example.com-error_log"
CustomLog "logs/dummy-host.example.com-access_log" common
</VirtualHost>

Is this correct? If it is it did not work -very frustrating.
adamon
 
Posts: 15
Joined: 19. February 2008 19:11

Postby jmdirc » 26. August 2008 18:51

No, you can see the difference here (this is how I keep mine):

Code: Select all
#<VirtualHost *:80>
#    ServerAdmin webmaster@dummy-host.example.com
#    DocumentRoot "/Applications/xampp/xamppfiles/docs/dummy-host.example.com"
#    ServerName dummy-host.example.com
#    ServerAlias www.dummy-host.example.com
#    ErrorLog "logs/dummy-host.example.com-error_log"
#    CustomLog "logs/dummy-host.example.com-access_log" common
#</VirtualHost>

#<VirtualHost *:80>
#    ServerAdmin webmaster@dummy-host2.example.com
#    DocumentRoot "/Applications/xampp/xamppfiles/docs/dummy-host2.example.com"
#   ServerName dummy-host2.example.com
#    ErrorLog "logs/dummy-host2.example.com-error_log"
#    CustomLog "logs/dummy-host2.example.com-access_log" common
#</VirtualHost>

<VirtualHost *:80>
DocumentRoot "/Applications/xampp/htdocs"
ServerName localhost
<Directory />
Options FollowSymLinks
AllowOverride All
</Directory>
</VirtualHost>
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Postby adamon » 26. August 2008 20:35

Thanks but no luck...

Is there possibly another work-around?
adamon
 
Posts: 15
Joined: 19. February 2008 19:11

Postby adamon » 26. August 2008 20:46

As always its the simple overlooked things that cause issues. I was advised to turn off web sharing in my control panel and it works fine.

Thanks for all the help!

Rob
adamon
 
Posts: 15
Joined: 19. February 2008 19:11

Postby jmdirc » 26. August 2008 21:25

I was always under the impression it wouldn't work with websharing off.

I just turned mine off and it does work. Hmm, wonder where I got the idea that websharing had to be on. Anyway, I've always had my websharing on since I serve a couple of web pages from here. So, if it works here with websharing on/off - then what is the difference between Tiger and Leopard?

So, If anyone knows, the question is unanswered should he want to serve pages at the same time as he developes sites.

If you now turn websharing back on does it work?
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Postby adamon » 26. August 2008 21:39

No, maybe the upgrades in firefox and safari access something in Leopard better than the previous versions. The older netscape worked fine with web sharing on.

Go figure.
adamon
 
Posts: 15
Joined: 19. February 2008 19:11

Postby jmdirc » 27. August 2008 02:06

Did you look through your security settings to see if there is something extra in there that could cause that problem? I have the latest versions of Safari and Firefox and both work fine with or without websharing on. It could be Apache. Can you compare your httpd.config in the xampp ap with the httpd.confg of the preinstalled Apache? or the vhost files? Or compare them to mine. Can you copy yours and zip it and email it to me?

If you don't care to thats ok; I'm just curious as to the difference.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests