Error stopping Apache

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Error stopping Apache

Postby collimarco » 28. July 2008 17:55

Hi all!

I get the following error whenever I stop Apache:


Code: Select all
Stopping XAMPP for MacOS X 0.7.3...
XAMPP: Stopping Apache...
/Applications/xampp/xamppfiles/bin/apachectl: line 70: ulimit: open files: cannot modify limit: Invalid argument
XAMPP: Stopping MySQL...
XAMPP: Stopping ProFTPD...
XAMPP stopped.



What does it mean? Is ther any method to fix it?

I am running XAMPP on Leopard (MAC OS X 10.5.4).

Thanks!
collimarco
 
Posts: 2
Joined: 28. July 2008 17:45

Postby jmdirc » 28. July 2008 18:52

go to file:

/Applications/xampp/xamppfiles/bin/apachectl

and comment out lines 69, 70 and 71

currently they are:

if [ "x$ULIMIT_MAX_FILES" != "x" ] ; then
$ULIMIT_MAX_FILES
fi

change to:

#if [ "x$ULIMIT_MAX_FILES" != "x" ] ; then
#$ULIMIT_MAX_FILES
#fi

See if that helps.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Postby collimarco » 28. July 2008 20:25

Solved! :D

Thanks a million
collimarco
 
Posts: 2
Joined: 28. July 2008 17:45

Postby jmdirc » 29. July 2008 01:37

OK, so how much money you got?

No, no, just kidding ! -- glad to be of help

This is a friendly community - you can always get answers here - sooner or later :wink:
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Re: Error stopping Apache

Postby eccleshall » 29. May 2009 23:04

I can only open it in Terminal and it doesn't have the code you have shown above

Thanks
eccleshall
 
Posts: 1
Joined: 29. May 2009 23:02

Re: Error stopping Apache

Postby matyre73 » 25. June 2009 07:36

I get this error in version Xampp 1.0.1

/Applications/XAMPP/xamppfiles/bin/apachectl: line 70: ulimit: open files: cannot modify limit: Invalid argument

Tried the above idea and then error still popped up but there was no msg just that there is an error. Any one got any idea's?
matyre73
 
Posts: 1
Joined: 25. June 2009 07:32

Re: Error stopping Apache

Postby DaViDz » 29. June 2009 14:45

hi, i've got the same issue as matyre73.

I just tried to start xampp by Terminal, then an "There is a problem in your etc/host problem, I'll fix it" error appears (or something like that).

Then I started it again from Terminal and it works. I stopped it from Terminal, tried to start xampp with the Control Panel and works correctly.

Maybe it´s a missconfiguration in etc/hosts file.

Bye !!!
DaViDz
 
Posts: 2
Joined: 29. June 2009 14:40

Re:

Postby sfgeorge » 10. December 2009 17:00

Hey gang, I know this quick-fix seems to work...
jmdirc wrote:go to file:

/Applications/xampp/xamppfiles/bin/apachectl

and comment out lines 69, 70 and 71

... but I would avoid commenting-out important functionality such as the ulimit max file check from apachectl. I was able to solve this same problem for myself by using Beverly Guillermo's tip that your apache user lacked the appropriate read and/or write permissions to the DocumentRoot, ErrorLog, or CustomLog.

In order to fix this properly, you need to know what User and Group settings you have for XAMPP, which you should be able to find in your /Applications/XAMPP/xamppfiles/etc/httpd.conf config file.

Next, verify that the User and Group have complete ownership of the content in your /Applications/XAMPP/logs/ (mine did not after I ran an OS X upgrade to Snow Leopard).

Next verify that an apache syntax check will work:
Code: Select all
sudo /Applications/XAMPP/xamppfiles/bin/apachectl -S

And last, for all of your VirtualHosts' DocumentRoots, you need to make sure that apache can read those directories and their contents. One way by doing this is by chgrp'ing each DocumentRoot so that the group matches your apache Group.

What do you gain by doing it the right way? A more stable apache instance, which you can upgrade easily without having to constantly re-patch your quick-fixes. Hope this helps.
sfgeorge
 
Posts: 2
Joined: 10. December 2009 16:28

Re: Error stopping Apache

Postby pedrocruz » 13. December 2010 19:40

Tried all these posts but the error still popped up with no message. Any idea's? Please....
pedrocruz
 
Posts: 1
Joined: 09. December 2010 19:29

Re: Error stopping Apache

Postby steve1234 » 24. January 2011 07:56

this is really fantastic forum to have.... I mean to say that a user 'collimarco' asked for the help and in no time one of the person who could solve the probelm did it.... great work "jmdirc" ... I really appreciate this and thanks to the admins / moderator team for making this really friendly forum....... gud luck to you all
steve1234
 
Posts: 1
Joined: 24. January 2011 07:52

Re: Error stopping Apache

Postby Manuzzi » 21. March 2011 21:24

Same for me: none of the posts worked.
I looked into the error_log of apache and there was this message:

"[Mon Mar 21 20:54:19 2011] [alert] (EAI 8)nodename nor servname provided, or not known: mod_unique_id: unable to find IPv4 address of "[mycomputername].fritz.box"
Configuration Failed"

I did an upgrade of the firmware of my Fritz Box modem and after that I could start Apache. Maybe it's just because of the restart of the modem after the upgrade, i don't know.

mac osx 10.6.6
apache/2.2.11
Manuzzi
 
Posts: 5
Joined: 28. October 2008 00:15
Location: Groningen NL

Re: Error stopping Apache

Postby Manuzzi » 19. September 2011 20:18

I now just pull out the network cable. When I do so starting or stopping apache is no problem.
Manuzzi
 
Posts: 5
Joined: 28. October 2008 00:15
Location: Groningen NL


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests