PhpMyAdmin and MySql passwords

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

PhpMyAdmin and MySql passwords

Postby TShirt » 07. June 2008 12:01

Hi all,
I'm a Xampp for Mac OS X newbie and I'm experiencing a password problem!
I start resuming what I've done 'till now!
I've:
1 - Dowloaded and installed Xampp (with the installer)
2 - Tested as documented on the web
3 - Run "mampp security" to change passwords
4 - Created a directory with soft links to htdocs to use it as my working dir (I don't like /Applications/.../htdocs! :wink: But changing a couple of lines in httpd.conf everithing works fine!)

Now ... if I open http://localhost ... no problems!
But if I click on PhpMyAdmin I get this error:

Error
MySQL said:
#1045 - Access denied for user 'root'@'localhost' (using password: NO)

I solved this issue under Windows changing the auth_type in config.inc.php to http but under Mac OS it does not seem to be the solution (I'm talking about /Applications/xampp/xamppfiles/phpmyadmin/config.inc.php)!!!

Am I missing something or doing something wrong?

Thanks in advance!


Bye...
TShirt
 
Posts: 9
Joined: 07. June 2008 11:26

Postby jmdirc » 07. June 2008 15:08

Isn't phpmyadmin usually set in the working directory? I would think changing the auth_type to http would do it. So,

For the sake of simplicity, I would just re-set phpmyadmin.

1. open the phpmyadmin folder
2. find the scripts folder
3. check and see if you have a setup.php file
4. if you do, go back to phpmyadmin folder and add 'sample' to the config file name, it will look like: config.sample.ini.php
5. Now, create a folder called config in the phpmyadmin folder(set perimissions of this folder to read and write for all)
6. now go to the browser and type in your address for phpmyadmin,
you will get an error page that will give you a link to the setup.php
go through the setup
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Postby TShirt » 07. June 2008 20:53

Nice try but ... it doesn't solve my problem!
The best I can do is to get the same output I had in the initial file! :)
Anyway ... the correct setting should be this?

$cfg['Servers'][$i]['auth_type'] = 'http';
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'mypwd';

If you have any other idea ... let me know!

Thanks a lot!!!



Bye...
TShirt
 
Posts: 9
Joined: 07. June 2008 11:26

Postby TShirt » 07. June 2008 21:42

I don't understand what was the magic!
I reinstalled everything and now it works!
I tried to access pma only after ALL the configurations I wrote in my first post and now it works!
In my first installation I tried to open pma before changing the config.inc.php; I don't know if this could be the problem ... but ... now it works!

Bye...
TShirt
 
Posts: 9
Joined: 07. June 2008 11:26

Postby jmdirc » 08. June 2008 01:32

Initially after you made the changes, did you forget to restart Xampp?

glad you got it going
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Postby TShirt » 08. June 2008 07:19

No! Every time I made a change I restarted Xampp!

Bye...
TShirt
 
Posts: 9
Joined: 07. June 2008 11:26


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests