localhost problem

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

localhost problem

Postby nordicbeastsixfootfive » 03. June 2008 22:24

i installed xampp on a new macbook that came with apache pre installed. after installing xampp and starting it and turning on web sharing, xampp works... but from the local ip address/xammp/index.php. when typing http://localhost - the browser returns the apache page, not xammp.

how do i fix it so http://localhost works the same as the
local ip address/xammp/index.php ?
nordicbeastsixfootfive
 
Posts: 3
Joined: 03. June 2008 22:17

Postby harkonenn » 16. July 2008 15:19

I second this request.

I can get to my local htdocs folder by entering 127.0.0.1 in a browser, but entering http://localhost brings me to the "Test Page for Apache Installation."

Do I need to virtualize localhost?

Please help!
harkonenn
 
Posts: 5
Joined: 25. September 2007 16:49

Postby jmdirc » 17. July 2008 16:17

Closest I can get you is http://localhost/whateverfilehere.php

if you want to reach the xampp index page - http://localhost/xampp/

How:

go to:
/Applications/xampp/etc/extra/httpd-vhosts.conf

add:
<VirtualHost *:80>
DocumentRoot "/Applications/xampp/htdocs"
ServerName localhost
<Directory />
Options FollowSymLinks
AllowOverride All
</Directory>
</VirtualHost>

you can comment out or delete the sample entries if you like (just keeping it clean)
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

More problems with localhost

Postby AndyC » 27. August 2008 11:44

OK I've tried the suggested fix above but still get the following displayed:

if you can see this, it means that the installation of the Apache web server software on this system was successful. You may now add content to this directory and replace this page.

Seeing this instead of the website you expected?

This page is here because the site administrator has changed the configuration of this web server. Please contact the person responsible for maintaining this server with questions. The Apache Software Foundation, which wrote the web server software this site administrator is using, has nothing to do with maintaining this site and cannot help resolve configuration issues.

The Apache documentation has been included with this distribution.

You are free to use the image below on an Apache-powered web server. Thanks for using Apache!

Any suggestions would be most appreciated.
AndyC
 
Posts: 11
Joined: 27. August 2008 11:32

Postby jmdirc » 27. August 2008 13:35

turn websharing off
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Postby AndyC » 27. August 2008 14:50

Already off unfortunately

:(
AndyC
 
Posts: 11
Joined: 27. August 2008 11:32

Postby jmdirc » 28. August 2008 03:19

Check your httpd.conf file:

xampp/etc/httpd.conf - check line 180 (your line numbers may be slightly different but this should get you in the neighborhood) for the directory where you will serve the pages from:

DocumentRoot "/Applications/xampp/xamppfiles/htdocs"

Then on lines 207 - 235:

<Directory "/Applications/xampp/xamppfiles/htdocs">

Options Indexes FollowSymLinks ExecCGI Includes

AllowOverride AuthConfig

Order allow,deny
Allow from all

</Directory>
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Postby AndyC » 28. August 2008 08:56

OK, thank you for that info but once again these instructions appear in httpd.conf where you suggest they should be. Any other suggestions?
AndyC
 
Posts: 11
Joined: 27. August 2008 11:32

Postby Nobbie » 28. August 2008 11:45

Nobbie
 
Posts: 6478
Joined: 09. March 2008 13:04

Postby AndyC » 28. August 2008 13:58

Thanks already tried that and get a message stating: Can not find server ! :(
AndyC
 
Posts: 11
Joined: 27. August 2008 11:32

Postby jmdirc » 28. August 2008 15:29

Below is an excerpt from my phpinfo.php - perhaps a comparison might help - This is from the Apache section -- I did exclude the Modules section and about my computer section:

apache2handler

Apache Version Apache/2.2.9 (Unix) mod_ssl/2.2.9 OpenSSL/0.9.8h DAV/2 PHP/5.2.6
Apache API Version 20051115
Server Administrator you@example.com
Hostname:Port bridget.local:0
User/Group nobody(-2)/80
Max Requests Per Child: 10000 - Keep Alive: on - Max Per Connection: 100
Timeouts Connection: 300 - Keep-Alive: 5
Virtual Server No
Server Root /Applications/xampp/xamppfiles


Directive Local Value Master Value
engine 1 1
last_modified 0 0
xbithack 0 0

Apache Environment

Variable Value
UNIQUE_ID SLa0TsCoAWQAAAb8ZHkAAAAB
HTTP_ACCEPT_LANGUAGE en
HTTP_ACCEPT_ENCODING gzip, deflate
HTTP_REFERER http://localhost/xampp/navi.php

HTTP_ACCEPT text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
HTTP_CONNECTION keep-alive
HTTP_HOST localhost
PATH /usr/bin:/bin:/usr/sbin:/sbin
SERVER_SIGNATURE no value
SERVER_SOFTWARE Apache/2.2.9 (Unix) mod_ssl/2.2.9 OpenSSL/0.9.8h DAV/2 PHP/5.2.6
SERVER_NAME localhost
SERVER_ADDR ::1
SERVER_PORT 80
REMOTE_ADDR ::1
DOCUMENT_ROOT /Applications/xampp/xamppfiles/htdocs
SERVER_ADMIN you@example.com
SCRIPT_FILENAME /Applications/xampp/xamppfiles/htdocs/xampp/phpinfo.php
REMOTE_PORT 51374
REMOTE_USER xampp
AUTH_TYPE Basic
GATEWAY_INTERFACE CGI/1.1
SERVER_PROTOCOL HTTP/1.1
REQUEST_METHOD GET
QUERY_STRING no value
REQUEST_URI /xampp/phpinfo.php
SCRIPT_NAME /xampp/phpinfo.php
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Postby AndyC » 28. August 2008 16:54

Right we might have something here. My phpinfo.php is empty, can you provide an example of what might/should be in this file. I'm affraid I have no idea at this level. Apart from the fact that I guess this file should not be empty. A sample content would be useful I'm running a MacBook Pro with OS X ver 10.5.4 installed.
AndyC
 
Posts: 11
Joined: 27. August 2008 11:32

Postby jmdirc » 28. August 2008 18:36

It's empty ?!

Go into the terminal and uninstall the xampp package completely. Just for adaquate measure, reboot your system and then re-install the 0.7.3 version.

To uninstall from the terminal:
Sign in as admin by typing 'sudo su' it will prompt you for a password,
once your signed in
Then type this exactly: rm -rf /Applications/xampp

Get new copy of vr 0.7.3 here:
http://www.apachefriends.org/en/xampp-macosx.html USE THE 'INSTALLER' VERSION

Perhaps something got wrong the first time around.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Postby AndyC » 29. August 2008 09:12

Once again thank you for your help and patience, I followed your last suggestion to the letter and after a reboot and install the phpinfo.php file was still empty! Well not quite empty it had the following entry

<?
phpinfo ();
?>

Confusing or what?
AndyC
 
Posts: 11
Joined: 27. August 2008 11:32

Postby jmdirc » 29. August 2008 13:38

---misunderstanding---

What your looking at is the code for phpinfo. Not what I meant. What your seeing by opening the file like you did is the function, it will display on a page all the information about your xampp configuration, apache, php and mysql and a little bit more. But in order for you to see it, it must be opened by way of the server not the browser. The browser can't read php. The way it works is the server interprets the php (server side) then sends to the browser an html version that the browser (client side) can understand.

Why don't you tell me what day and time you can be on here, in the forum, and we can talk about what is going on with xampp - we can talk through pms.

Does it appear to launch ok?
After the install is it working with http://localhost ? Turn on xampp and then click on this link http://localhost/
Do you get the welcome screen for xampp?

If you get the Xamp welcome screen and you click on your language do you get an orange page with a long list of links to the left ? Read down that list until you reach phpinfo - click on that and that will take you to the page which has the above information (from my other post)
Last edited by jmdirc on 29. August 2008 14:06, edited 3 times in total.
User avatar
jmdirc
 
Posts: 154
Joined: 10. February 2008 22:44

Next

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests