Very Hig auto increment id

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Very Hig auto increment id

Postby cropcreativos » 11. May 2008 04:42

I have installed Apache friend in Mac and Windows. I have installed wordpress, but I cannot work, cannot create entries, pages categories, etc. I have observed that the increase the number of ID is too high, though I not has entered even pages. How to configure the number of autoincrease, in order that does not jump of 80 to 2017612633061982209
Posts: 1
Joined: 11. May 2008 04:27

Postby kcmartin » 20. May 2008 07:08

I'm having the same problem with XAMPP 0.7.2 on Mac.

All MySQL fields that WordPress uses with auto_increment are generating huge numbers.

Like the original poster of this thread, I cannot create valid new posts, pages or categories in wordpress (actually they are in the database, but wordpress does not seem to think they are valid).

I tried installing and reinstalling XAMPP and WordPress on two machines, one with Leopard (10.5.2) and one with Tiger (10.4.11). Same issue.

BTW, I tried MAMP with Wordpress (It installs an older version of MySQL) and everything works fine.

Any info on this is appreciated.
Posts: 1
Joined: 20. May 2008 06:57

Postby liquidx » 21. May 2008 09:56

we're in the same boat..

i noticed that the mysql auto increment option will generate huge numbers although i've restricted it to only generate 2 digits of int, or bigint for example.

and i'm too using XAMPP 0.7.2 on Mac
Posts: 13
Joined: 21. May 2008 09:34

Postby liquidx » 23. May 2008 03:31

found out that the bug came from the mysql itself, not the xampp package..

i ended up by installing a different version of mysql (mysql-5.0.51b-osx10.4-2-powerpc) at a different location and to make it workable with existing php from xampp, i simply make a softlink of the mysql.sock to the location that the xampp's php is expecting (.../xamppfiles/var/mysql/bin/mysql.sock -> /tmp/mysql.sock).

i then wrote a shell script to start/stop all xampp's services but it's mysql service, and the new mysql deamon.

and it worked like a charm
Posts: 13
Joined: 21. May 2008 09:34

another work-around

Postby beepy » 02. July 2008 17:30

Another work-around: before you install, edit wp-admin/include/schema.php and replace all instances of bigint(20) with int(11).
Posts: 1
Joined: 02. July 2008 17:27

Postby Milligan » 03. July 2008 01:22

Last edited by Milligan on 17. July 2008 04:14, edited 1 time in total.
Posts: 136
Joined: 03. March 2008 06:23

Why does this happen?

Postby EvanDonovan » 12. July 2008 18:04

Thanks, beepy. Your fix worked. I'm mystified by why this happens, though. Is this a bug with the way that build 5.0.51a handles bigint which was fixed in build 5.0.51b? I couldn't find it on the MySQL bug tracker.

Does anyone know if there will be a future release of XAMPP/Mac soon which includes the version of MySQL without this bug? WordPress is a pretty common install, I imagine.
Posts: 1
Joined: 12. July 2008 18:00

Postby th1alb » 12. October 2008 07:59

I do have the same bug when using cakePHP with XAMPP for Mac OS X 0.7.3.

BIGINT creates high auto increment ids, while INT does not.

Hope this will be fixed somehow, as it cost me hours to find out what was wrong.

Thank you for a otherwise great piece of software.
Posts: 98
Joined: 31. August 2005 21:14

Return to XAMPP for macOS

Who is online

Users browsing this forum: No registered users and 9 guests