xampp at leopard startup

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

xampp at leopard startup

Postby filipefreitas » 06. May 2008 13:43

Hi,

I´ve been trying to start xampp at startup (on Leopard)

I´ve written this script and placed it in /Librabry/LaunchAgents

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>org.apachefriends.xampp</string>
<key>ProgramArguments</key>
<array>
<string>/Applications/xampp/xamppfiles/mampp</string>
<string>start</string>
</array>
<key>RunAtLoad</key>
<true/>
</dict>
</plist>

then I wrote:
sudo launchctl load -w /Library/LaunchDaemons/org.apachefriends.xampp.plist

It didn´t work

What s the best way? How do you guys do it?

thx
filipefreitas
 
Posts: 1
Joined: 06. May 2008 12:37

Re: xampp at leopard startup

Postby zazerh » 17. May 2008 02:59

Hi,

I wanted to do the same thing and created a .plist file that seems to work. I actually put it in /Library/LaunchDaemons rather than LaunchAgents because I want it to run as a root background process.

Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC -//Apple Computer//DTD PLIST 1.0//EN http://www.apple.com/DTDs/PropertyList-1.0.dtd >
<plist version="1.0">
<dict>
   <key>Label</key>
   <string>XAMPP</string>
   <key>Program</key>
   <string>/Applications/xampp/xamppfiles/mampp</string>
   <key>ProgramArguments</key>
   <array>
      <string>start</string>
   </array>
</dict>
</plist>


Hopefully this will work for you. I just named it xampp.list.

Edit: Just realized that org.apachefriends.xampp is probably a better name and Label
zazerh
 
Posts: 2
Joined: 17. May 2008 02:51
Location: Palo Alto, CA

slight modification

Postby zazerh » 28. May 2008 07:11

Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC -//Apple Computer//DTD PLIST 1.0//EN http://www.apple.com/DTDs/PropertyList-1.0.dtd >
<plist version="1.0">
<dict>
   <key>Label</key>
   <string>org.apachefriends.xampp</string>
   <key>ProgramArguments</key>
   <array>
      <string>/Applications/xampp/xamppfiles/mampp</string>
      <string>start</string>
   </array>
   <key>RunAtLoad</key>
   <true/>
</dict>
zazerh
 
Posts: 2
Joined: 17. May 2008 02:51
Location: Palo Alto, CA

Postby Polat » 28. May 2008 07:52

Will this even work when you login without root/administrator privileges?
Polat
 
Posts: 6
Joined: 26. May 2008 09:06

Postby liquidx » 28. May 2008 08:06

Polat wrote:Will this even work when you login without root/administrator privileges?


yes it suppose to
liquidx
 
Posts: 13
Joined: 21. May 2008 09:34

Postby Polat » 28. May 2008 09:59

zazerh: Your script is not complete, you've forgot </plist> at the end of the script.
liquidx: Nope, it is not working, it does only work if the user has administrator privileges.
28-05-08 10:55:03 org.apachefriends.xampp[505] You need to start XAMPP as root!


/edit
Now it does work, placed the script in LaunchDaemons instead of LaunchAgents.
Polat
 
Posts: 6
Joined: 26. May 2008 09:06


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 6 guests