PEAR problem

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

PEAR problem

Postby bgarner » 08. February 2008 18:27

I am getting the following error after installing CalemEAM on XAMPP:

Warning: require_once(PEAR.php) [function.require-once]: failed to open stream: No such file or directory in /Applications/xampp/xamppfiles/htdocs/CalemEAM/server/include/SOAP/Base.php on line 47

Fatal error: require_once() [function.require]: Failed opening required 'PEAR.php' (include_path='/Applications/xampp/xamppfiles/htdocs/CalemEAM/server/include:.:/usr/lib/php/PEAR.php') in /Applications/xampp/xamppfiles/htdocs/CalemEAM/server/include/SOAP/Base.php on line 47


I have added:
include_path=".:/Applications/xampp/xamppfiles/lib/php/pear"
...to the php.ini file that is found in xamppfiles/etc, but the error is showing that it is looking in /usr/lib/php for PEAR.php

Am I doing something wrong? Does anybody have any ideas?
-Brandon
bgarner
 
Posts: 3
Joined: 08. February 2008 18:17

PEAR problem

Postby bgarner » 08. February 2008 23:50

Fixed. After inputing the correct include_path and restarting XAMPP, all seems to be working fine. Sorry to bug anyone.
-Brandon
bgarner
 
Posts: 3
Joined: 08. February 2008 18:17

same issue

Postby tykus » 31. July 2008 15:29

What path did you edit to resolve this? I'm also trying to test Calem but I'm not that good at XAMPP or php
tykus
 
Posts: 3
Joined: 31. July 2008 06:49

shameless bump

Postby tykus » 31. July 2008 21:45

anyone?
tykus
 
Posts: 3
Joined: 31. July 2008 06:49

Postby bgarner » 31. July 2008 21:49

It has been a few months since I messed with this...and to be honest, we aren't using this solution after all. It was a testing phase to see if we wanted to use CalemEAM, but it didn't fit our needs. So, that said, I think I remember that I had to edit the php.ini configuration file and then restart XAMPP, which reloads the php configuration from the config (.ini) file.

Have you done this already?
-Brandon
bgarner
 
Posts: 3
Joined: 08. February 2008 18:17

Thanks for the reply

Postby tykus » 31. July 2008 23:49

Thank you for replying bgarner,

at the time, I noticed the same exact error message you had and did open php.ini to add the same include path.

include_path=".:/Applications/xampp/xamppfiles/lib/php/pear"

I've restarted XAMPP but still get teh same error message....
(btw, what did you end up going with to manage your IT assets?)


Warning: require_once(PEAR.php) [function.require-once]: failed to open stream: No such file or directory in /Applications/xampp/xamppfiles/htdocs/CalemEAM/server/include/SOAP/Base.php on line 47

Fatal error: require_once() [function.require]: Failed opening required 'PEAR.php' (include_path='/Applications/xampp/xamppfiles/htdocs/CalemEAM/server/include:.:/Applications/xampp/xamppfiles/lib/php') in /Applications/xampp/xamppfiles/htdocs/CalemEAM/server/include/SOAP/Base.php on line 47
tykus
 
Posts: 3
Joined: 31. July 2008 06:49


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 5 guests