Switch PHP Versions for PEAR Use

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Switch PHP Versions for PEAR Use

Postby neight718 » 05. September 2007 22:22

I am trying to install a PEAR Package (HTML_Quickform2) which is only compatible with PHP5. I have PHP5 set in the XAMPP contorl panel, but when I download the PEAR Package it says it cannot install becuase the PHP Version is 4.4.7. How do I switch that or just completely uninstall PHP4?

Posts: 1
Joined: 05. September 2007 22:19

Postby reticulator » 07. November 2007 21:44

I too have set php to php5 using the control panel (or mampp), but it looks like it's not as thorough as it might be. I'm new to PEAR, but I see this:
Code: Select all
$ pear config-show | grep extension
PHP extension directory  ext_dir /Applications/xampp/xamppfiles/lib/php/php4/extensions/no-debug-non-zts-20020429

Could this be your problem?
Posts: 3
Joined: 07. November 2007 21:31
Location: California, USA

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests