installing additional PHP libraries

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

installing additional PHP libraries

Postby april » 27. February 2007 22:33

Anyone know how to install memcache on xampp? I have the ye old PPC version, and can't use the newest versions of xampp.
april
 
Posts: 24
Joined: 09. January 2007 19:06

Postby irakli » 23. April 2007 06:10

I tried to install memcache on XAMPP (on LINUX but it's still related I imagine). I installed the latest XAMPP 1.6.1, installed XAMPP-Devel, too and tried to compile memcache with PECL.

PECL failed with phpize error. Then I tried using phpize/configure/make/make install, which went through just fine but when I start Apache, memcache does not get loaded into PHP, I can see the following error in the PHP error log:

PHP Warning: Unknown(): Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20020429/memcache.so' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20020429/memcache.so: undefined symbol: OnUpdateLong in Unknown on line 0

I googled this error and people say it happens when PHP is compiled with --enable-versioning option because this option is broken.

If that is truly the case - can somebody release a patch to XAMPP that which will be a version compiled WITHOUT the versioning so memcache works?

Any help is appreciated :(
irakli
 
Posts: 4
Joined: 23. April 2007 06:06

Postby irakli » 23. April 2007 22:42

Hey,

I was actually able to get it done on Linux. It had NOTHING to do with "enable version" anything. Googling for troubleshooting sucks :)

here is a step-by-step guide of what I did:

http://www.freshblurbs.com/install-pecl-memcache-xampp-and-php4


cheers
irakli
 
Posts: 4
Joined: 23. April 2007 06:06


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 5 guests