FTP Users

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

FTP Users

Postby mistermartin75 » 05. December 2006 09:00

It could be just me having this problem, but I cannot seem to log on to the MAMPP FTP server. I'v read that ProFTPD uses the /etc/passwd file, but my username is not in there. How do you log in to your FTP on a Mac?
mistermartin75
 
Posts: 30
Joined: 02. November 2005 09:50

Postby jens_k » 22. January 2007 21:19

Hi mistermartin!
I just downloaded and installed xampp today an have had the same promlem.
If you want to use the user nobody you have to modify the following file.
/Applications/xampp/etc/proftpd.conf

There should be a line with the following content:
UserPass nobody XXXXXXXX (where 'XXXXXXXX' is your encrypted password)
simply add a line above with the content:
RequireValidShell off

I don't remember I you have to restart the proftp-deamon. After this it worked fine for me.


Hopes I could support you.
Best regards,
Jens
jens_k
 
Posts: 11
Joined: 22. January 2007 15:41

Postby mistermartin75 » 22. January 2007 22:42

Yeah, I know :) It's in the bug tracker already. But thanks for you reply :D
mistermartin75
 
Posts: 30
Joined: 02. November 2005 09:50

Postby jens_k » 22. January 2007 22:44

didn't know if you solved it - i hate unanswered threads ;-)
jens_k
 
Posts: 11
Joined: 22. January 2007 15:41

Re: FTP Users

Postby acejbird » 09. February 2009 04:16

I am just trying to get XAMPP working on my Mac as well and I've managed to get everything to work except the ProFTP instance for XAMPP. I am running into the same issue that was originally posted on this and I can't seem to get it fixed. I've tried running the security script and also changing the "nobody" user account password using the "passwd" command and that hasn't helped either. It's my understanding that the ProFTP installation tries to use the system users and defaults to "nobody" but for some reason this doesn't seem to be working.

One odd thing that I noticed with my installation is that once I got everything installed and started and I went to the "security" page on the XAMPP installation, it already showed the password for the "nobody" user as having been changed from "xampp" when I hadn't even run the security script and when I ran the security script it told me that the password was already not "xampp" and asked if I still wanted to change it anyway.

So I'm wondering if there was an already existing "nobody" user that is causing me grief - I just can't seem to determine how to proceed. I've tried editing the /Applications/xampp/etc/proftpd.conf file and had no success; in fact, there's no line in that file for "UserPass nobody XXXXXXXX (where 'XXXXXXXX' is your encrypted password)" - there's no line with "UserPass" at all and it seems it would be impossible to add the correct information for that line manually since the XXXXXXXX is the encrypted password anyway and not clear text. Anyway, without this line, it seems pretty pointless to make the addition of another line for "RequireValidShell off", although I tried adding one just for grins and the ProFTP server daemon will start but still no luck on logging in.

Anyway, I need the FTP server working for some of the scripts I'm trying to run to work and I'd prefer to not have to install something else as a file server if I can help it as I like the idea of having an all-in-one solution that XAMPP provides. If anyone can help that would be greatly appreciated.
acejbird
 
Posts: 1
Joined: 09. February 2009 04:05

Re: FTP Users

Postby riddle » 11. February 2009 22:08

This is a big fat "me too" for acejbird's post of February 8.

I'm using a fresh XAMPP 0.7.4 install on Mac OS X 10.5.6. I am unable to log into my FTP server using any combination of usernames and passwords that I can think of. When I ran "mampp security" for the very first time I got the "XAMPP: ProFTPD has a new FTP password. Great!" message even though I obviously had not set an FTP password. Whether or not I try to change the FTP password, there are no "UserPass" lines in etc/proftpd.conf.

At this point I don't even understand what the correct behavior is supposed to be, let alone how or why the configuration might be broken. I imagine it's too much to hope that it might be documented somewhere, right? :-)

In January 2007 Jens said that proftpd.conf should contain these lines (where XXXXXXX is an encrypted password):

Code: Select all
RequireValidShell off
UserPass nobody XXXXXXXX


Is that correct and is it sufficient? Is there anything else with security implications that might be missing from my proftpd.conf file? I'm already getting probed by mysterious Russian IP addresses, so I certainly don't want to open a hole while trying to correct my login problem...

Thanks.
riddle
 
Posts: 6
Joined: 10. February 2009 17:22

Re: FTP Users

Postby riddle » 11. February 2009 22:44

Addendum: I tried the RequireValidShell/UserPass directives I quoted from Jens in my previous post (having added a properly encrypted password) and they didn't work for me.

But I also tried this stanza from the mysterious proftpd.conf.rej file:

Code: Select all
#to login with "OSX Users"
AuthPAM on
AuthPAMConfig ftpd


...and that did work! With those lines in place I could FTP into localhost using my Mac username and password.

However, my security doubts remain. I don't want to use my Mac password in the clear and I'm concerned about what else might be wrong with my configuration. I guess I'll just turn off ProFTP. Pity.
riddle
 
Posts: 6
Joined: 10. February 2009 17:22

Re: FTP Users

Postby nasam » 21. March 2009 08:06

Add to proftpd.conf save and restart ProFTPD

Code: Select all
# nobody gets the password "xampp"
RequireValidShell off
UserPassword nobody J7DcFO7VNmbCQ


login with username : nobody , password : xampp
or use mampp security to change password
nasam
 
Posts: 1
Joined: 21. March 2009 07:51


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 8 guests