SolveD!!!!!!! Mysql deactivated message.

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

SolveD!!!!!!! Mysql deactivated message.

Postby machelp » 27. September 2006 00:21

....(n.d.r- the solution in last message..)
Not a great issue BUT...

At first go into Startup Items in Lybrary and delete all concerning Apache and mysql startup...


If you stopped all Serverlogistics, MarcLiyanage, and APPLE STUFF...

From sharing preferences panes,
and deactivating the "start on boot" checkboxes, from APACHE and MYSQL pane...

If you also tried to stop your pureftpd FTP server from PureFTPD manager
This is what cause your xampp PROftpd ftp dont start...

i found a way... brutal...

Open Application-Utility-Activity Monitor
select other user processes from popup menu..
From Terminal write
Code: Select all
/Applications/xampp/xamppfiles/mampp stop

At this point in activity monitor app, all you find as sql and httpd and ftp,
are SURE NOT from xampp environment ,

this mean you have something is running also:

    Apple ftp-apache(personalwb/fileserver) ,
    serverlogistics mysql or apache 2 (in Library -Apache2),
    TEnon Itools 7-8 (you have to uninstall with a proprietary tool),
    MArc liyanage apache build,
    other Apache/mysql/php suite....

If they wont deinstall..or are still working..

KILL THEM from activity monitor and restart xampp

MAde this And restarted my mac the Xampp seems stable...

I remade the same after password change...

Now it works again...
Is not acceptable, need a fix,
but...hope this helps...

Last edited by machelp on 28. September 2006 03:30, edited 2 times in total.
Posts: 3
Joined: 26. September 2006 20:53

Definitively not a solution....

Postby machelp » 28. September 2006 01:29

Just worked...twice, but solved nothing...
please kill this not useful post,
or help!!!!!!!!!!!!!!


Code: Select all
host199-177-dynamic:~ root# /Applications/xampp/xamppfiles/bin/mysql.server start
Starting MySQL................................... ERROR!
host199-177-dynamic:~ root#

..... made some brickwall game too with permissions..
Posts: 3
Joined: 26. September 2006 20:53

Postby machelp » 28. September 2006 01:56

------ DEFiNitiVELY SOLVED..for me...

Code: Select all
060928 02:25:19  mysqld started
060928  2:25:19 [Warning] Setting lower_case_table_names=2 because file system for /Applications/xampp/xamppfiles/var/mysql/ is case insensitive
060928  2:25:19  InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name ./ibdata1
InnoDB: File operation call: 'open'.
InnoDB: Cannot continue operation.
060928 02:25:19  mysqld ended

..... selected the xampp/xamppfiles folder... applied 777 to enclosed items too...

It works..!!

Posts: 3
Joined: 26. September 2006 20:53

2002 errors, mysql deactivated and on 10.4.8 intel mac

Postby m4cluv3r » 30. November 2006 18:27

Thank you so much for this useful post :D

For those having similar issues - here is the probs and steps I took for Intel Macs with 10.4.8.

I had 0.5 installed on my Intel Mac, and only recently had been getting 2002 errors (strangely after I did some OSX updates) when I tried to view via phpadmin - which said "unable to connect to socket". When I would start XAMPP via command line, there were no error messages for MySQL, just said Starting MySQL. I looked in the error log in /Applications/xampp/xamppfiles/var/mysql which did say permissions were a problem, so I had chmoded on just the directories, but it is key to include changing permissions on the files themselves.

I had reinstalled 0.5 multiple times which seemed to work - but only temporarily then I would get the "deactivated" status and the 2002 error. In the error log, it would say couldnt find the mysql.sock or the mysqld.frm or even mysqld. So I tried to install the 0.6 version and got problems with fopen php errors after I would select the language on the splash screen. I didn't see much help on this issue, so I tried reinstalling. I found not only did I have to rm -rf, but I had to empty trash (as this post suggests), reboot, and after installing, make sure the xamppfiles and more specifically the files in the /Applications/xampp/etc directory were 775. Make sure that xampp/xamppfiles/my.cnf has 775 permissions - not 777 - as it doesn't like world-writeable permissions for mysql.

Hope this helps!
Posts: 1
Joined: 30. November 2006 18:00

Postby mistermartin75 » 05. December 2006 08:57

You guys should install the app as noted on the macosx page for xampp. NOT unzip and drag-and-drop, but use the command given with the installation instructions, otherwise you break all the file permission. Doing it that way solves the problem with MySQL and xampp will work perfectly then.
Posts: 30
Joined: 02. November 2005 09:50

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests