confusing issues with xampp setup

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

confusing issues with xampp setup

Postby dashauer » 22. April 2006 22:04

I setup XAMPP because I really am not a hardcore web server person. I get the basics, can change config files, but if I tried to install everything from source I'm almost guaranteed to ruin my entire system.

I got XAMPP installed, got into NetInfo manager to setup, I can access my sites - hooray for me!

However, my sites don't work whatsoever and I'm now baffled. Here is what happens...

I have a site that uses clean urls and thus rewrite rules. It appears all the rewrites are working. However, the application usually stops halfway through (where it has worked on my PC localhost and on a live server). I tried debugging by randomly echo'ing in places to find where the application stops. Now it gets weird...

First - after every request, I have to restart apache. If I hit refresh in the browser two times, the second time it just hangs for infiniti.

Second - The spot in the application where the application ends is different almost every time. Again, this was found by echo'ing out after every 10-20 lines of code.

Thirdly, and most odd - If I make a change, reload apache, hit refresh, it does it's usual random spot in the application crash. However, if I reload apache immediately (without refreshing again, thus making a second request) it then hangs until infiniti on the first try after restarting apache. So, in order to test a change, I have to make two requests then restart apache.
dashauer
 
Posts: 5
Joined: 22. April 2006 01:53

Postby capitalfellow » 23. April 2006 15:09

Logging is your friend. It's much more effective than simple echo statements. If you haven't set a LogLevel directive for the virtualhost that is not behaving the way you expect set:

LogLevel info
ErrorLog /full/path/to/your/site/logs/yoursite-error.log
CustomLog /full/path/to/your/site/logs/yoursite-access.log

Under your mod_rewrite directives set:

# Debug: mod_rewrite logging
RewriteLog /full/path/to/your/site/logs/yoursite-rewrite.log
RewriteLogLevel 3

If you need more rewrite logging detail you can set the LogLevel up to 9. When you're done debugging just remove the directives.
User avatar
capitalfellow
 
Posts: 60
Joined: 19. July 2005 01:10
Location: Charlotte, NC USA
XAMPP Version: 5.5.19
Operating System: OS X

Postby dashauer » 23. April 2006 18:26

I was logging everything, none of it made sense. Anyway, I got everything setup withou XAMPP so all is good now.
dashauer
 
Posts: 5
Joined: 22. April 2006 01:53


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests