HOWTO: Upgrade PEAR 1.35 to 1.4.9 with XAMPP for OS X .4

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

HOWTO: Upgrade PEAR 1.35 to 1.4.9 with XAMPP for OS X .4

Postby capitalfellow » 21. April 2006 16:36

We don't use XAMPP for OS X .5 because MySQL 5 is bundled in it. Out of the box, trying to use the PEAR installer with AF seems to be broken. The PEAR packages are stored (assuming standard install) in /Applications/xampp/xamppfiles/lib/php.

The problem is while AF created a pear directory to hold all PEAR classes below the pear directory there is also a PEAR package itself. Moving the PEAR package into pear/PEAR doesn't make the pear installer work correctly. We have to move the existing PEAR packages into the pear directory:

su -
cd /Applications/xampp/xamppfiles/lib/php
mv PEAR pear
mv pearcmd.php pear
mv Archive/ pear/
mv Console/ pear/
mv DB* pear/
rm -rf pear/Mail*
mv Mail* pear/
mv Net/ pear/
mv OS/ pear/
mv PHPUnit* pear/
rm -rf pear/XML
mv XML/ pear/
mv System.php pear/
pear list


pear upgrade-all would exceed the memory_limit set in php.ini from 8 Mb to 16 Mb to 32 Mb until setting 64 Mb memory limit caused pear to segfault. This is on a PPC 12" Powerbook with 512 Mb RAM. Thus:

Do not upgrade PEAR until the very last package
pear upgrade <each-package-one-at-a-time>
pear upgrade PEAR
User avatar
capitalfellow
 
Posts: 60
Joined: 19. July 2005 01:10
Location: Charlotte, NC USA
XAMPP Version: 5.5.19
Operating System: OS X

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest