how to set password for phpmyadmin config file?

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

how to set password for phpmyadmin config file?

Postby meggrace » 08. February 2006 05:21

I got through the security settings fine and set passwords for XAMPP pages, MySQL, and FTP. That's all I was prompted for in Terminal. Then opened XAMPP start page (http://localhost)

At the XAMPP start page, I clicked on phpmyadmin and new window gave me this message - a pop-up menu for Language: set to English (en-iso-8859-1). A "GO" button and beneath that this message: "Error. The configuration file now needs a secret passphrase (blowfish_secret)."

What's odd is I am not prompted for a password. I just get this window. I can, however, open phpmyadmin Lite.

I'm sorry to say, clicking on the link for manual brings me to http://www.apachefriends.org/en/xampp-macosx.html - no manual in sight. :(

I appreciate the work that went into this package - what a great idea! I hope someone has an answer to my problem. Thanks!
meggrace
 
Posts: 2
Joined: 08. February 2006 04:57
Location: Portland, OR

I GOT it.

Postby natebiehl » 14. February 2006 20:44

...fighting this thing all morning as well..
You have to actually hand edit the config.inc.php file.

First you have to change permissions in a lot of directories so that you have read/write access to all of the files in /xampp/xamppfiles/phpmyadmin

Then I opened the config.inc.php file in textedit (use whatever you usually use to code PHP...I've never hand coded PHP before today, so I had to adjust textedit's preferences a little.)

I wanted to KEEP the password protection, so I DID NOT change the password.

What I DID change was the authorization type so that I actually got a login page when I hit the phpmyadmin link.

To do this, I changed the "$cfg['Servers'][$i]['auth_type'] = 'config';" line to read "$cfg['Servers'][$i]['auth_type'] = 'http'; "

Then I saved the page.

As I understand it, This changes the autorization type to an http based login page, where you can now enter "root" as your username and your new password to login.

If I'm getting the logic behind this wrong, I'm a SERIOUS NEWBIE with develpment, so someone should call me on it so I know.

Anyway, this worked for me. I hope it works for you.
natebiehl
 
Posts: 1
Joined: 14. February 2006 20:27

Postby threewishmonkeypaw » 17. July 2006 21:28

i got the same problem...
what worked for me was make myself the file owner.. and with the auth_type set to "config" i set my mysql password below it... then set the owner of the config.ini.php file back to "nobody"
threewishmonkeypaw
 
Posts: 8
Joined: 17. July 2006 12:20


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests