MySQL won't start on Tiger with .5 release

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

MySQL won't start on Tiger with .5 release

Postby lexton » 07. January 2006 09:19

I'm trying to get mysql to start properly with the .5 release on tiger.

when I launch xampp is says (in the terminal) that mysql has started but it lists as deactivated in the Status page.

In addtion nestat does not list it as running and I can't connet with telnet on port 3306, etc...

I do notice that if I manually start mysql -> mampp startmysql

and then do:

ps aux | grep mysql

I get this for about a minute or two and then the process dies:

root 769 0.2 0.1 27820 676 p0 S 3:13AM 0:00.08 /bin/sh /Applications/xampp/xamppfiles/bin/mysql.server start

I've made sure that my orginal install of mysql is not running when I try to run the xampp version.

any suggestions appreciated
lexton
 
Posts: 4
Joined: 07. January 2006 07:08

nasty solution!

Postby lexton » 11. January 2006 21:27

Hi all,

this is what I was getting in my mysql error log:

060111 14:35:28 mysqld started
060111 14:35:28 [Warning] Setting lower_case_table_names=2 because file system for /Applications/xampp/xamppfiles/var/ is case insensitive
060111 14:35:28 InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name ./ibdata1
InnoDB: File operation call: 'create'.
InnoDB: Cannot continue operation.
060111 14:35:28 mysqld ended

So this looks like a file permission issue.

thus I did this:

sudo chown -R nobody /Applications/xampp/xamppfiles/var/mysql

and MySQL is now running properly.

however what should be the default file permissions for this directory?
lexton
 
Posts: 4
Joined: 07. January 2006 07:08


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests