Defining Test Server Folder in Dreamweaver on Mac

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Defining Test Server Folder in Dreamweaver on Mac

Postby Slack » 22. December 2005 04:04

Hey,

I am currently creating a basic application using dreamweaver, php and mysql on a Mac (OS X 10.3). I don't have too much knowledge on this stuff so be gentle.

To do all the php and mysql stuff I have installed XAMPP for Mac. Installation went fine and all components are active.

I am having problems defining the site in Dreamweaver MX 2004. By the way I will be using the same machine that acts as a web server and used to edit the web pages. I have got the following info:

Local Info Section:
Site Name = My Site
Local root folder = Macintosh HD:MySitePages:
HTTP address = http://

Remote Info Section:
Access = Local/Network
Remote Folder = Macintosh HD:MySitePages:

Test Server Section:
Server Model = PHP MySQL
Access = Local/Network
Testing server folder = Macintosh HD:Applications:xampp:htdocs
URL prefix = http://localhost/

I have created a template which is stored in Macintosh HD:MySitePages:Templates. When I try to preview the template page in my browser I get the following messages which I click YES to:

Update Copy on Test Server? YES
Include dependent files? YES

After doing this I get the following error:

"Unable to create remote folder Macintosh HD/Applications/xampp/htdocs/Templates/. Access was denied."

After clicking OK to the error a "NOT FOUND - The requested URL /Templates/mysitetemplate.dwt.php was not found on this server." page is displayed in the browser.

I have tried to change the folder (xampp and htdocs) permissions but still that has made no difference.

I have not made any modifications to the php.ini file, would I need to do this?

In the php.ini file, is there something that needs to be placed in extension_dir = "./" ?

On my laptop running Win 2000 XAMPP and Dreamweaver work fine without any problems.

Sorry, I know this is quite detailed but does anyone know how to fix this?

Thanks
Slack
 
Posts: 2
Joined: 22. December 2005 03:46

Issue resolved

Postby Slack » 22. December 2005 19:11

Answer is not required as I have now I have now fixed the problem. Solution:

Placed my web page folder in htdocs folder, changed folder permissions for xampp and htdocs and changed url prefix. Looks somethng like this:

Local Info section
Local root folder = Macintosh HD:Applications:xampp:htdocs:MySitePages

Remote Info section
Remote folder = Macintosh HD:Applications:xampp:htdocs:MySitePages

Test server section
test serer folder = Macintosh HD:Applications:xampp:htdocs:MySitePages
URL Prefix = http://localhost/MySitePages/

No modification made to php.ini
Slack
 
Posts: 2
Joined: 22. December 2005 03:46

Postby desmund » 17. October 2006 13:21

Slack, how did you change folder permissions for xampp and htdocs?

I'm also having problems with setting up DW MX to hook up with my local server. But I can't create new folders because it's write protected.

I tried right-clicking the folders in Dreamweaver, but this time the permissions setting is not even there. Funny..

Hope it's not too complicated to explain it. Thank you...
desmund
 
Posts: 3
Joined: 17. October 2006 09:30


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests