XAMPP 0.4 Def causes sys hang on shutdown

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

XAMPP 0.4 Def causes sys hang on shutdown

Postby alanvee » 07. September 2005 01:36

This is a follow-on post to my previous comment about XAMPP.

I had to do a restart of the Apache server and issued the command:
/Applications/xampp/xampfiles/mampp restart

here is the screen output:

Stopping XAMPP for MacOS X 0.4...
XAMPP: Stopping Apache with SSL...
XAMPP: Stopping MySQL...
XAMPP: Stopping ProFTPD...
XAMPP stopped.
Starting XAMPP for MacOS X 0.4...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...


...and the cursor never returns untill I type a ctrl-C.

After this (and this has ALWAYS happend) when I do a system restart (Mac OS 10.4.2) it shuts down to a plain blue screen and then hangs with a twirling pinwheel. And it stays there until I press the restart button.

I have a number if shortcuts on the desktop (and dual monitors) and after the last restart the desktop icons where jumbled all over.

I'm worried about that hang after Apache restart. Is 0.5 coming out anytime soon?

=Alan R.
alanvee
 
Posts: 7
Joined: 02. September 2005 12:39

Postby Kristian Marcroft » 08. September 2005 22:54

Hi,

first of all thank you for your feedback,
Though we can not really say what is going wrong.

There is no timescale for 0.5 yet. But if we don't know what the problem is in 0.4 then 0.5 wont be much different.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby tak » 28. September 2005 09:21

I have exactly the same problem unable to shutdown my mac mini
w/ osx 10.4.2 and XAMPP 0.4.I didn't have this problem on osx 10.3.9.

It comes from that the proftpd process cannot be killed
by mampp.It can't be killed even manually from terminal w/
command 'kill -9',so the process stays and system waits
forever when shutdown

Apple changed the daemon control to launchd from 10.4.x
and it might be causing the problem because the parent
process of the proftpd process is launchd(at least Activity Monitor
says so) but it is merely a guess.
tak
 
Posts: 3
Joined: 08. June 2005 14:43
Location: Kyoto,Japan

Postby Kristian Marcroft » 28. September 2005 09:27

Hi,

yes, this is still an open issue.
We will have a look at this for the next release.

Thank you

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests