Beta 0.2's MySQL seems to be dead when using Tiger

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Beta 0.2's MySQL seems to be dead when using Tiger

Postby MikeThomsen » 30. May 2005 03:11

I'm using Tiger and get the following error when I try to run mysql after I have started the daemon:

mike-thomsens-powerbook-g4-12:/Applications/xampp/xamppfiles mikethomsen$ bin/mysql --user=root
dyld: Library not loaded: /Applications/xampp/xamppfiles/lib/mysql/libmysqlclient.14.dylib
Referenced from: /Applications/xampp/xamppfiles/bin/mysql
Reason: image not found
Trace/BPT trap

I have set DYLD_LIBRARY_PATH equal to the mysql lib directory, absolute path, not relative. Still fails. Any thoughts? I have Fink installed so I should be able to use the MySQL client from that to connect to XAMPP's bundled MySQL server, but that's a little too ghetto for my tastes if there is any way to do get around this problem. Do y'all have a shell script or something I can run to build Beta 0.2 on my powerbook using the Tiger development toolchain?
MikeThomsen
 
Posts: 1
Joined: 30. May 2005 03:06

Postby PF4 » 31. May 2005 06:16

Hi,

try to run mysql as root.
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby MySchizoBuddy » 11. June 2005 20:49

works perfectly fine with me running 10.4.1
:P
MySchizoBuddy
 
Posts: 12
Joined: 11. June 2005 20:46

Postby jksellors » 07. August 2005 03:04

MySQL would not start after XAMPP install— becourse the instance of MySQL used on the original Apple setup was still running.
I changed the autostart StartupItems plist and quit MySQL then started XAMPP.
jksellors
 
Posts: 7
Joined: 05. August 2005 19:05


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 8 guests