fastcgi module

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

fastcgi module

Postby lisamac » 17. April 2005 05:57

Hey Gang,

trying to install the fastcgi module to run with Apache so I can speed up my ruby on rails development.

When I do the usual apxs install from other apache version I get the following:

Lisas-Laptop:/Developer/src/mod_fastcgi-2.4.2 lisa$ sudo /usr/local/xampp/bin/apxs mod_fastcgi.so -c *.c
Password:
cannot open /usr/local/xampp/build/config_vars.mk: No such file or directory at /usr/local/xampp/bin/apxs line 218.

I have a feeling it's because of an incorrect apxs executable since I got it working using the same command on an earlier install today (non XAMPP version).

Thought I'd post a notice about it for future development (even including the fastcgi module would be great... it'll get used more in the future I'm sure) - hope it helps us move toward a stable release :-)

In the meantime, would anyone know how I can work around this? I've never installed a module with Apache without using apxs unless I build it in the compile. Since I can't use either I feel like my hands are tied... :oops:

Many thanks in advance for any help you could provide.
I'm running 10.3.9 :-)
lisamac
 
Posts: 1
Joined: 17. April 2005 05:49

Postby Kristian Marcroft » 17. April 2005 09:26

Hi,

the error youare getting, is because you have not got the required Development Files.

With the next release (which we don't know when it will be),
we will also serve a dev-package as we do for the linux version.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests