Changing requiredMemory in metadata.json doesn't work

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Changing requiredMemory in metadata.json doesn't work

Postby AcidSlide » 04. September 2021 20:26

Hi All,

I have 2 installations of XAMPP VM for MacOS (2 different computers). I have installed the latest (at the time of this post) VM Version on the second machine (xampp-osx-7.4.23-0-vm.dmg). My other machine is using 7.4.20-0.

I've updated the metadata.json of the newer machine (v7.4.23-0) and changed the
Code: Select all
"requiredMemory": 1024
to
Code: Select all
"requiredMemory": 2048
but running
Code: Select all
free -h
only shows 1GB of memory. I don't have an issue with the other machine which is now using 2GB of memory.

Image Image URL: https://pasteboard.co/Kj5ilud.png

I hope somebody can help me!

Thanks in advance!
AcidSlide
 
Posts: 3
Joined: 24. November 2019 00:38
XAMPP version: 7.3.11-0 (VM)
Operating System: MacOS (Mojave/Catalina)

Re: Changing requiredMemory in metadata.json doesn't work

Postby AcidSlide » 11. September 2021 01:22

Now this is weird.. after a couple of days of not running XAMPP-VM.. the requiredMemory settings in the metadata.json now works.. super weird!????

I'm not sure why it wasn't working back then.. i've restarted my machine a couple of times back then but still didn't work.. but now for some very weird and unknown reason the VM is now using 2GB of memory
AcidSlide
 
Posts: 3
Joined: 24. November 2019 00:38
XAMPP version: 7.3.11-0 (VM)
Operating System: MacOS (Mojave/Catalina)


Return to XAMPP for macOS

Who is online

Users browsing this forum: No registered users and 9 guests