XAMPP for OS X 7.2.28-0 and Need to Install MCRYPT

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

XAMPP for OS X 7.2.28-0 and Need to Install MCRYPT

Postby avelureno » 16. September 2020 01:00

I am running a local server for my magento site development before any code gets pushed to Staging or Production.

I had to update my XAMPP from PHP 5 to XAMPP 7.2.28-0 because of my staging and production being pushed to PHP 7. In doing so my local magento no longer functions properly because MCRYPT is absolutely needed.

How do I install mcrpyt on my local to be able to use in XAMPP OS X 7.2.28-0? Otherwise I will if I do not find a solution here I will have to stop using XAMPP, which I LOVE, and create a new environment from scratch which Im not looking forward too.

Please help!!
User avatar
avelureno
 
Posts: 2
Joined: 23. March 2018 21:33
Location: United States
XAMPP version: 7.2.28-01
Operating System: Mac OSX 10.15

Re: XAMPP for OS X 7.2.28-0 and Need to Install MCRYPT

Postby Nobbie » 16. September 2020 09:46

You cannot install mcrypt, as it has been removed from PHP with PHP 7.2. It was marked as "deprecated" with PHP 7.1

See also https://wiki.php.net/rfc/mcrypt-viking-funeral

Ask magento what they are planning for PHP 7.2 ff., as they have to replace mcrypt as well. Mcrypt development already stopped more than 10 years ago with no support anymore, therefore PHP development decided to remove it.
Nobbie
 
Posts: 11673
Joined: 09. March 2008 13:04


Return to XAMPP for macOS

Who is online

Users browsing this forum: No registered users and 5 guests