apache web server not working with https

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

apache web server not working with https

Postby pcfreak49 » 06. November 2018 11:26

Hello everyone I have a problem I want to use https the moment I use this port 443 the apache web server does not start on anyone knows how the certificate https I created

My localhost
<VirtualHost *: 443>
     ServerName localhost
     ServerAlias www.localhost.be
     ServerAdmin info@test.be
     SSLEngine on
     SSLCipherSuite ALL:! ADH:! EXPORT56: RC4 + RSA: + HIGH: + MEDIUM: + LOW: + SSLv2: + EXP: + eNULL
     SSLCertificateFile /Applications/XAMPP/etc/ssl/localhost.crt
     SSLCertificateKeyFile /Applications/XAMPP/etc/ssl/localhost.key
     DocumentRoot "/ Applications / XAMPP / htdocs /"
     <Directory "/ Applications / XAMPP / htdocs /">
         Options Indexes FollowSymLinks Includes ExecCGI
         AllowOverride All
         Require all granted
     </ Directory>
     ErrorLog "logs / localhost.be-error_log"
     CustomLog "logs / localhost.be-access_log" common
</ VirtualHost>
pcfreak49
 
Posts: 3
Joined: 06. November 2018 10:52
XAMPP version: 7.2.11.1
Operating System: Macos Mojave

Re: apache web server not working with https

Postby Nobbie » 06. November 2018 21:08

You have to buy a certificate for SSL connections, i recommend to google for "certificate for SSL" in order to get proper advice where to get official SSL certificates.
Nobbie
 
Posts: 10544
Joined: 09. March 2008 13:04

Re: apache web server not working with https

Postby Altrea » 06. November 2018 22:29

pcfreak49 wrote:     DocumentRoot "/ Applications / XAMPP / htdocs /"
     <Directory "/ Applications / XAMPP / htdocs /">

     ErrorLog "logs / localhost.be-error_log"
     CustomLog "logs / localhost.be-access_log" common
</ VirtualHost>

Are there really whitespaces in your paths?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9335
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache web server not working with https

Postby pcfreak49 » 07. November 2018 09:00

it is to be tested on localhost, I have already modified the file httpd-vhosts.conf and httpd-ssl.conf, but the apache server is no longer working and path is correct because on port 80 it does work
pcfreak49
 
Posts: 3
Joined: 06. November 2018 10:52
XAMPP version: 7.2.11.1
Operating System: Macos Mojave

Re: apache web server not working with https

Postby pcfreak49 » 10. November 2018 17:49

I managed to use both http and https
pcfreak49
 
Posts: 3
Joined: 06. November 2018 10:52
XAMPP version: 7.2.11.1
Operating System: Macos Mojave


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests